A1052 Linked List Sorting(25分)PAT 甲级(Advanced Level) Practice(C++)满分题解【链表地址+排序]

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (<105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [−105,105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:

5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:

5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

题意分析:

先将原始输入数据存入srclist中,然后根据节点的address和next来遍历找出相连接的节点存入linked_list链表,然后对linked_list根据key值从小到大的顺序排序,并记录有效节点的个数,最后再进行输出。

注意输出时要更新节点的next地址值,为linked_list链表中下一个节点的address地址值。

但是仅作上述操作后测试点3会fail,后来看了其他人的题解后,发现要注意当输入的起始地址start为-1时,此时应该要输出“0 -1”,加上这个判断后就AC了。

代码如下:

#include<bits/stdc++.h>
using namespace std;
struct node {
	string address, next;
	int key;
	bool flag;//是否为有效数据
};
int n, valid_n = 0;
string start;
vector<node> srclist,linked_list,sorted_list;
map<string, node> addressIndex;
bool cmp(node a, node b) {
	return a.key < b.key;
}
int main()
{
	cin >> n >> start;
	srclist.resize(n);
	for (int i = 0; i < n; i++) {
		cin >> srclist[i].address >> srclist[i].key >> srclist[i].next;
		addressIndex[srclist[i].address] = srclist[i];
	}
	if (start == "-1")
		cout << "0 -1" << endl;
	else {
		//组成链表
		for (int i = 0; i < n; i++) {
			if (srclist[i].address == start) {
				string nextAddr = srclist[i].address;
				while (nextAddr != "-1") {
					valid_n++;
					linked_list.push_back(addressIndex[nextAddr]);
					nextAddr = addressIndex[nextAddr].next;
				}
			}
		}
		//按值从小到大排序
		sort(linked_list.begin(), linked_list.end(), cmp);
		string newStart = linked_list[0].address;
		//更新排序后每个节点的地址和下一个地址,输出
		cout << valid_n << " " << newStart << endl;
		for (int i = 0; i < valid_n - 1; i++) {
			cout << linked_list[i].address << " " << linked_list[i].key << " " << linked_list[i + 1].address << endl;
		}
		cout << linked_list[valid_n - 1].address << " " << linked_list[valid_n - 1].key << " " << "-1" << endl;
	}
	return 0;
}

运行结果如下:

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值