poj 2406 Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 34584 Accepted: 14310

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意:求每个测试字符串的周期长度。

解题思路:利用KMP算法的next数组。next数组以0开始时,若len%(len-next[x]+1)不为0,则周期串是其本身,若不为0,周期长度为len/(len-next[x]+1).

解题过程:如果next数组起始值不同,周期长度求取公式稍有差异,注意不要混淆。

代码如下:

#include <cstdio>
#include <cstring>
const int maxn=1000010;
int next[maxn];
int len,x; 
char s[maxn];
void get_next()
{
    int i=1,j=0;
    next[1]=0;
    while(i<=len)
    {
        if(j==0||s[i]==s[j])
        {
            i++;
            j++;
            next[i]=j;
        }
        else
            j=next[j];
    }  
	x=i;
}

int main()
{
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]=='.')break;
        len=strlen(s);
		for(int i=len;i>0;i--)
			s[i]=s[i-1];
		get_next();
		if(len%(len-next[x]+1))
			printf("1\n");
		else
        printf("%d\n",len/(len-next[x]+1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值