poj 1050 To the Max

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41890 Accepted: 22255

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15


题目链接:http://poj.org/problem?id=1050


题目大意:求一个n乘n矩阵的最大子矩阵。


解题思路:DP。根据求最大子串的方法,把二维矩阵转换为一维的形式,即合并行,合并成一行时每一列的各行直接相加即可。然后转换成多次求最大子串问题,最大值不断更新。


代码如下:

#include <cstdio>
#include <cstring>
#define MIN -0xffffff
const int maxn=105;
int a[maxn][maxn];
int b[maxn];   //转换成最大子串问题时用来存储一维串的数组
int main()
{
    int i,j,k,n,ans,tem,sum;
    scanf("%d",&n);
	ans=MIN;
    for(i=0;i<n;i++)
        for(j=0;j<n;j++)
            scanf("%d",&a[i][j]);
    for(i=0;i<n;i++)
    {
        memset(b,0,sizeof(b));  
        for(j=i;j<n;j++)  //行压缩从i开始,第一次i行作为一行,第二次i行和i+1行合并成一行,第三次i行和i+1行和i+2行合并成一行......
        {
            sum=0;
            tem=MIN;
            for(k=0;k<n;k++)
            {
                b[k]+=a[j][k];   //合并行
                sum+=b[k];       
                if(sum>tem)		//tem用于记录第前k个数的最大子串和
                    tem=sum;
                if(tem>ans)
                    ans=tem;
                if(sum<0)     
                    sum=0;
            }
        }
    }
    printf("%d\n",ans );
    return 0;
}
/*DP求最大子矩阵*/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值