HDU 5135 Little Zu Chongzhi's Triangles

Little Zu Chongzhi's Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 470    Accepted Submission(s): 248


Problem Description
Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent mathematician computed a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere.

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.
2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.
3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help him so that maybe you can change the history.
 

Input
There are no more than 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length of a stick is no more than 100. The input ends with N = 0.
 

Output
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .
 

Sample Input
  
  
3 1 1 20 7 3 4 5 3 4 5 90 0
 

Sample Output
  
  
0.00 13.64


题目大意:提供一些木棍,每三根首尾相连用来组成一个三角形(长度符合条件),求各个三角形总面积最大是多少。


解题思路:贪心,木棍长度从大到小排序,不能组成三角形的木棍舍去,用海伦公式求出组成的三角形的面积。


代码如下:

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
double a[13];
double area(double a,double b,double c)  //海伦公式,已知三角形三边边长求面积
{
    double p=(a+b+c)/2.0;
    return sqrt(p*(p-a)*(p-b)*(p-c));
}
int main()
{
    int n,i;
    double ans;
    while(scanf("%d" ,&n)!=EOF&&n)
    {
        ans=0.0;
        for(i=0;i<n;i++)
            scanf("%lf",&a[i]);
        sort(a,a+n);     //排序
        for(i=n-1;i>=2;i--)  //按边长递减顺序,保证的满足条件的每个三角形边长最大
        {
            if(a[i]<a[i-1]+a[i-2])   //只用判断最长边是否小于另外两边之和
			{
                ans+=area(a[i],a[i-2],a[i-1]);  
				i-=2;
			}
        }                            //若不满足条件,该最长边直接舍去
        printf("%.2f\n",ans );
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值