hdu5135 Little Zu Chongzhi's Triangles

Little Zu Chongzhi's Triangles

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1899    Accepted Submission(s): 1082


Problem Description
Zu Chongzhi (429–500) was a prominent Chinese mathematician and astronomer during the Liu Song and Southern Qi Dynasties. Zu calculated the value ofπ to the precision of six decimal places and for a thousand years thereafter no subsequent mathematician computed a value this precise. Zu calculated one year as 365.24281481 days, which is very close to 365.24219878 days as we know today. He also worked on deducing the formula for the volume of a sphere. 

It is said in some legend story books that when Zu was a little boy, he liked mathematical games. One day, his father gave him some wood sticks as toys. Zu Chongzhi found a interesting problem using them. He wanted to make some triangles by those sticks, and he wanted the total area of all triangles he made to be as large as possible. The rules were :

1) A triangle could only consist of 3 sticks.
2) A triangle's vertexes must be end points of sticks. A triangle's vertex couldn't be in the middle of a stick.
3) Zu didn't have to use all sticks.

Unfortunately, Zu didn't solve that problem because it was an algorithm problem rather than a mathematical problem. You can't solve that problem without a computer if there are too many sticks. So please bring your computer and go back to Zu's time to help him so that maybe you can change the history.
 

Input
There are no more than 10 test cases. For each case:

The first line is an integer N(3 <= N<= 12), indicating the number of sticks Zu Chongzhi had got. The second line contains N integers, meaning the length of N sticks. The length of a stick is no more than 100. The input ends with N = 0.
 

Output
For each test case, output the maximum total area of triangles Zu could make. Round the result to 2 digits after decimal point. If Zu couldn't make any triangle, print 0.00 .
 

Sample Input
  
  
3 1 1 20 7 3 4 5 3 4 5 90 0
 

Sample Output
  
  
0.00 13.64
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6022  6021  6020  6019  6018 
 
题意:给出n个木棍,围成几个三角形,使得围成所有三角形的面积和最大
思路:透过现象看本质;什么时候三角形的面积最大?等边三角形的面积最大,所以我们尽可能的取得三条边相等的三角形;

代码:
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;

const int maxn=100;
double a[maxn];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        for(int i=0;i<n;i++)
            scanf("%lf",&a[i]);

sort(a,a+n);
        double ans=0;
        for(int i=n-1;i>=2;i--)
        {
//            printf("%.2lf ",a[i]);
            if(a[i-1]+a[i-2]>a[i])
            {
                double p=(a[i]+a[i-1]+a[i-2])*1.0/2;
                double s=sqrt(p*(p-a[i])*(p-a[i-1])*(p-a[i-2]));
                ans+=s;
                i-=2;
            }
            else
                continue ;
        }
//printf("\n");
        printf("%.2lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值