poj 3278 Catch That Cow (BFS+剪枝)

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 58474 Accepted: 18173

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source


题目链接:http://poj.org/problem?id=3278


题目大意:数字n到k,每次只能通过三种变换中的一种,即+1,-1或*2,求最少变换次数。


解题思路:BFS,剪枝特别重要,需要visit数组标记,已变换过的数字不再加入队列,能极大程度地提高效率。数组开大概200000的范围,超过次范围的数字舍去。一开始以为会出现负数,但仔细想想,因为n和k都是非负整数,变换过程如果出现负数不会是最优解,因此标记时不必考虑下标为负的情况。


代码如下:

#include <cstdio>
#include <queue>
using namespace std;
const int maxn=200010;
int m,n;
int vis1[maxn];
struct node
{
	int x,step;
};
int bfs()
{
	node sd;
	sd.x=n;
	sd.step=0;
	queue<node>q;
	q.push(sd);
	while(!q.empty())
	{
		node nd=q.front();
		if(nd.x==m)
			return nd.step;
		q.pop();
		for(int i=0;i<3;i++)//枚举三种变换方法
		{
			if(i==0)
			{
				sd.x=nd.x-1;
				sd.step=nd.step+1;
				if(sd.x>=0&&!vis1[sd.x])  //该数字没有访问过,可加入队列
				{
					vis1[sd.x]=1;
					q.push(sd);
				}
			}
			else if(i==1)
			{
				sd.x=nd.x+1;
				sd.step=nd.step+1;
				if(sd.x>maxn)         //超出最大范围的数字舍去
					continue;
				if(sd.x>=0&&!vis1[sd.x])  
				{
					vis1[sd.x]=1;
					q.push(sd);
				}
			}
			else
			{
				sd.x=nd.x*2;
				sd.step=nd.step+1;
				if(sd.x>maxn)
					continue;
				if(sd.x>=0&&!vis1[sd.x])
				{
					vis1[sd.x]=1;
					q.push(sd);
				}
			}
		}
	}

}
int main()
{
	scanf("%d%d",&n,&m);
	printf("%d\n",bfs() );
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值