hdu 5137 How Many Maos Does the Guanxi Worth (最短路SPAF实现)

How Many Maos Does the Guanxi Worth

                                                Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
                                                                       Total Submission(s): 847    Accepted Submission(s): 322



Problem Description
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school. Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

Input
There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30, 3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 

Output
For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

Sample Input
  
  
4 5 1 2 3 1 3 7 1 4 50 2 3 4 3 4 2 3 2 1 2 30 2 3 10 0 0
 

Sample Output
  
  
50 Inf
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5390  5389  5388  5387  5386

题目连接:http://acm.hdu.edu.cn/showproblem.php?pid=5137

题目大意:一个点代表一个人,老板是1,校长是n,若两个人之间有金钱交易的关系,那他们能相互付钱办事,所有人组成一张关系网。老板要通过贿赂的方式送儿子进学校,而你能说服一个人不接受贿赂,这个人不能使校长或老板。求能否让老板的计谋得逞,若能输出Inf,若不能阻止,尽量让老板付出最多的金钱,求老板至少准备多少钱。

解题思路:最短路问题。SPAF求解,枚举能说服的那个人,每次得到一条最短路,求所有最短路中最长的一条即可,如果最长的一条是正无穷,则说明老板不能得逞。

代码如下:

#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
#define inf 1e9
using namespace std;
int const maxn=105;
int n;
int dist[maxn],vis[maxn];  //dist记录最大能量值,vis标记点是否访问过
struct node   
{ 						
	int v,w;
	node(int vv,int ww)
	{
		v=vv;
		w=ww;
	}
};
vector <node> vt[maxn];
void SPAF(int v0,int x)
{
	memset(vis,0,sizeof(vis));    
	for(int i=0;i<maxn;i++)
		dist[i]=inf;
	queue <int>q;
	q.push(v0);
	dist[v0]=0;            
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		vis[u]=0;
		int len=vt[u].size();         
		for(int i=0;i<len;i++)  //注意要得到最短路,当v为n时不能返回,要把图遍历后才能得到最短路
		{
			int v=vt[u][i].v;
			int w=vt[u][i].w;
			if(v==x)            //x是不接受贿赂的人,此路径跳过
				continue;
			if(dist[v]>dist[u]+w)    
			{
				dist[v]=dist[u]+w;
				if(!vis[v])
				{
					vis[v]=1;
					q.push(v);
				}
			}
		}
	}
}
int main(void)
{
	int m,u,v,w;
	while(scanf("%d%d",&n,&m)!=EOF&&(n+m))
	{
		int ans=0;
		for(int i=0;i<maxn;i++)
			vt[i].clear();
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&u,&v,&w);
			vt[u].push_back(node(v,w));
			vt[v].push_back(node(u,w));
		}
		for(int i=2;i<n;i++)
		{
			SPAF(1,i);
			ans=max(ans,dist[n]);
			if(dist[n]==inf)
				break;
		}
		if(dist[n]==inf)
			printf("Inf\n");
		else
			printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值