【PAT 甲级】1001 A+B Format

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

题目大意:求两个数的和,并用三位分节法表示结果。

注意这里用到了一个新的取整数位数的方法,参考:点击打开链接

	if(abs(sum)>1)
	{//取整数位数
	        len=1+(int)log10(abs(sum));
	}

我的完整代码如下:

#include <iostream>
#include <cmath>
#include <string>
using namespace std;
int main()
{
	int a,b,sum,i=1,temp,len=1;
	cin>>a>>b;

	sum=a+b;
	if(abs(sum)>1)
	{//取整数位数
	        len=1+(int)log10(abs(sum));
	}
	int *s= new int [len+2]; //动态分配数组
	
	if(sum==0)
	{//如果合为0,直接输出0
		cout<<'0';
		system("pause");
		return 0;
	}
	temp=sum;

	while(sum!=0)
	{//从个位开始逐位存入
		s[i]=sum%10;
		sum=sum/10;
		i++;
	}

	//输出
	if(temp<0)
	{
		cout<<'-';
	}
	for(int j=i-1;j>=1;j--)
	{
		if(j%3==0&&j!=i-1)
		{
			cout<<',';
		}
		cout<<abs(s[j]);
	}

        delete[] s;
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值