【PAT甲级 C++】1001. A+B Format 数字相加格式化输出

1001. A+B Format (20)-PAT甲级真题

Calculate a + b and output the sum in standard format — that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

计算 a + b 并以标准格式输出总和 — 也就是说,数字必须用逗号分隔为三组(除非少于四位数字)。

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

思路:

将结果转换为字符数组然后输出,
通过取余数和除法,将数字拆成数字数组,然后输出即可。

代码及解释如下:

//12,345,678
//12,345,678
#include<stdio.h>
#include<vector>
#include <iostream>

using namespace std;

int main() {
	int a, b;
	cin >> a >>  b;
	int sum = a + b;
	//结果等于0时
	if (sum = 0) {
		cout << 0;
		return 0;
	}
	//结果小于0时,提出负号,sum变成绝对值
	//为了和结果为正数时统一处理
	if (sum < 0) {
		cout << '-';
		sum = sum * (-1);
	}
	
	//转换为单个字符
	vector<int> v;
	while (sum != 0) {
		v.push_back(sum % 10);
		sum = sum / 10;
	}
	//从高位到低位依次输出
    for (int i = v.size() - 1; i >= 0; i--) {
		cout << v[i];
		//判断每3位输出一个','
		//且最后一位不能为','
		if (i > 0 && i % 3 == 0) cout << ',';
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值