1029 Median(25 point(s)(cj)

1029 Median(25 point(s))

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

1.5M的内存限制,真的太小了,也就370000个int大小,所以不能把数组全存下来,可以先存一部分,另一部分边比较边输入。

 

#include <stdio.h>
#include <iostream>
using namespace std;
int a[200015];
int main(){
    int len1,len2;
    scanf(" %d",&len1);
    for(int i=0;i<len1;++i){
        scanf(" %d",&a[i]);
    }
    scanf(" %d",&len2);
    int sta = (len1+len2+1)/2;
    int x,p1=0,num=0,val;
    bool f=0;
    for(int i=0;i<len2;++i){
        scanf(" %d",&x);
        while(p1<len1&&a[p1]<=x) {
            num++;
            val=a[p1++];
            if(num==sta) {
                f=1;break;
            };
        }
        if(f) break;
        num++;
        val=x;
        if(num==sta) break;
    }
    while(num<sta){
        num++;
        val=a[p1++];
    }
    printf("%d",val);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值