【PAT甲级】1029 Median(25 分)

题目链接

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题意:两个非递减序列合并,求合并后的中位数

思路:首先容易想到的是直接合并然后输出中位数,但是会超内存;超内存的原因是所有的数都保存了,那么就尝试不保存所有的数值,只保存一个序列的,由于两个序列都是非递减的,所以可以用另一个序列的第一个数与第一个序列的第一个数比较, 直到找到中位数。 使用队列,为方便处理,在队列尾部加入INT_MAX,这是t is guaranteed that all the integers are in the range of long int. 决定的。 

代码:

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <cmath>
#include <cstdio>
#include <string>
#include <vector>
#include <climits>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define lowbit(i) ((i)&(-i))
typedef long long ll;
typedef unsigned long long ull;
const ll INF=0x3f3f3f3f;
const int N = 1e2+5;

queue<int>que1,que2;
int main(){
    int n,m,x;
    scanf("%d",&n);
    rep(i,0,n){
        scanf("%d",&x);
        if(x>INT_MAX) x=INT_MAX;
        que1.push(x);
    }
    que1.push(INT_MAX);
    scanf("%d",&m);
    int cnt=0;
    int targetId=(n+m-1)/2;
    rep(i,0,m){
        scanf("%d",&x);
        if(x>INT_MAX) x=INT_MAX;
        que2.push(x);
        if(cnt==targetId){
            printf("%d",min(que1.front(),que2.front()));
            return 0;
        }
        if(que1.front()<que2.front()){
            que1.pop();
        }else {
            que2.pop();
        }
        cnt++;
    }
    que2.push(INT_MAX);
    while(cnt<targetId){
        if(que1.front()<que2.front()) que1.pop();
        else que2.pop();
        cnt++;
    }
    printf("%d",min(que1.front(),que2.front()));
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值