1146 Topological Order(25 分)
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:
Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.
Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4
code
#pragma warning(disable:4996)
#include <iostream>
#include <vector>
using namespace std;
vector<int> graph[1005];
vector<int> input(1005);
vector<int> res;
bool istopological();
int main() {
int n, m;
cin >> n >> m;
int x, y;
for (int i = 0; i < m; ++i) {
cin >> x >> y;
graph[x].push_back(y);
input[y]++;
}
int k;
cin >> k;
bool f = 1;
for (int i = 0; i < k; ++i) {
res.clear();
for (int i = 0; i < n; ++i) {
cin >> x;
res.push_back(x);
}
if (istopological()==0) {
if (f) f = 0;
else cout << ' ';
cout << i;
}
}
system("pause");
return 0;
}
bool istopological() {
vector<int> copy = input;
for (int i = 0; i < res.size(); ++i) {
if (copy[res[i]] != 0) return 0;
for (int j = 0; j < graph[res[i]].size(); ++j) {
--copy[graph[res[i]][j]];
}
}
return 1;
}