1146 Topological Order(25 分)

1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

 

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
vector<int>vec[1005];
vector<int>v;
int num[1005];
int main() 
{
	int n,m,a,b;
	scanf("%d%d",&n,&m);
	for(int i = 1;i<=m;i++)
	{
		scanf("%d%d",&a,&b);
		vec[a].push_back(b);
		num[b]++;//表明完成这个任务需要先完成哪些 
	}
	int k;
	scanf("%d",&k);
	int dd[1005],gg[1005];
	for(int p = 0; p < k ; p++)
	{
		for(int i = 1;i <= n ;i++)
		{
			dd[i] = num[i];
			scanf("%d",&gg[i]); 
		}
		for(int i = 1;i <= n; i++)
		{
			if(dd[gg[i]] != 0)
			{
				v.push_back(p);	
				break;
			}else  //表示他等于0 了 那么把他vector里面的东西各自减一 
			{
				int size = vec[gg[i]].size();
				for(int j = 0;j < size; j++)
					dd[ vec[gg[i]][j] ]--;
			}
		}	
	}
	int o = v.size();
	for(int i = 0;i<o;i++)
		printf("%d%c",v[i]," \n"[i==o-1]);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值