C - 4 Values whose Sum is 0

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n . Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
之前碰到一个类似的题,当时是三个序列,现在只不过多了一个,这类问题由于时间上的限制好像只能选择二分,但这题有个坑,二分查找已查到就会返回,无法获知是否还有其他满足条件的情况,所以在
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
int A[4005],B[4005],C[4005],D[4005],sum1[4005*4005],sum2[4005*4005];//这里不能用long long,不然会爆内存;
int bf(int s[],int k,int x)
{
    int low=0,high=k-1,mid;
    while(low<=high)
    {
        mid=(low+high)>>1;
        if(s[mid]==x)return mid;
        else if(s[mid]<x)low=mid+1;
        else high=mid-1;
    }
    return -1;
}
int main()
{
    int n;
    //freopen("1.txt","r",stdin);
    while(cin>>n)
    {
        for(int i=0;i<n;i++)cin>>A[i]>>B[i]>>C[i]>>D[i];
        int k=0;int q=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++){sum1[k++]=A[i]+B[j];sum2[q++]=C[i]+D[j];}
        }
        sort(sum1,sum1+k);int flag=0;
        for(int i=0;i<k;i++)
        {
            int t,t1,t2;t=bf(sum1,k,-1*sum2[i]);
            if(t!=-1)
            {
                flag++;
                /*for(t1=t+1;;t1++)//确定二分无法探查的其他情况
                    {
                        if(sum1[t1]==sum1[t])flag++;//原本以为思路是对的应该能ac,但结果就是错,后来发现是循环应加上结束条件,虽然我自以
                        else break;    //有了break就可以高枕无忧了,看来还是应该少用这种形式的循环很容易出错
                    }
                for(t2=t-1;;t2--){
                    if(sum1[t2]==sum1[t])flag++;
                    else break;
                }*/下面是修改后的代码
                flag++;t1=t+1;
                while(t1<k&&sum1[t1++]==sum1[t])flag++;
                t2=t-1;
                while(t2>=0&&sum1[t2--]==sum1[t])flag++;

            }
        }
        cout<<flag<<endl;
    }
}


主函数里又根据二分返回的结果去确定了其他的情况,确保不遗漏;
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值