B - A+B (III)

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b ( 1 <= a, b <=1016 ) , separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input
1 5
10 20
10000000000000000 10000000000000000
0 0
Sample Output
6
30
20000000000000000
原本以为定义个longlong就能解决问题,有试了double,结果发现两个类型都都会失去精度;然后只能用数组,结果数组没初始化,好久都没发现,不细心啊  

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include<algorithm>
#include<math.h>
#include<string>
using namespace std;
int main()
{
    string str1,str2;int a[200],b[200],c[200];

    while(cin>>str1>>str2&&str1!="0")
    {
        memset(a,0,sizeof(a));memset(b,0,sizeof(b));
        reverse(str1.begin(),str1.end());
        reverse(str2.begin(),str2.end());
        for(int i=0;i<str1.length();i++)
        {
            a[i]=str1[i]-48;
        }
        for(int i=0;i<str2.length();i++)
        {
            b[i]=str2[i]-48;
        }
        int j=0,x=0;
        while(j<str2.length()||j<str1.length())
        {
            c[j]=a[j]+b[j]+x;x=c[j]/10;c[j]%=10;j++;
        }
        c[j]=x;if(0==x)j--;
        for(int i=j;i>-1;i--)cout<<c[i];
        cout<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值