Radar Installation

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

 
Figure A Sample Input of Radar Installations


 

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

    题目大意:以x轴为分界,y>0部分为海,y<0部分为陆地,给出一些岛屿坐标(在海中),再给出雷达可达到范围,雷达只可      以安在陆地上,问最少多少雷达可以覆盖所以岛屿
 

   考虑最左边的一个岛屿A,要用一个雷达去覆盖它,又要使得之后的岛屿会尽可能的都在这个雷达的范围里,那么雷达在覆盖A     的条件下越往左放置越好,即A刚好在雷达扫描的边界上为最优,我们可以以此来求出雷达的坐标,然后判断继A之后有哪些岛     屿在刚刚放置的雷达范围之中,若在便从队列中除去,若不在便以此岛屿再次执行与A一样的操作(即找下一个雷达的布置位       置)。

   后来发现这种做法是错误的,在放置第一个雷达时,在满足覆盖A的同时,并不是越往右放置越好,因为当雷达往右挪动时,       会将不再覆盖左侧的一部分(如图阴影部分),此时B点将需要另外添加一个雷达来覆盖,故这种思路是错误的!

     那么该怎么做呢?我们可以这样想,既然我要用一个圆尝试着(雷达范围,半径为r)去覆盖岛屿,那为何不以岛屿为圆心r为       半径画一个圆(记为圆O),于是只要雷达在这个圆里那么这个岛屿就能被覆盖。而从前面的分析可知,雷达必然要布置在x       

     轴上,所以雷达肯定放在圆O与x轴的那段交线区间上,如图:

 

#include <iostream>
#include <algorithm>
#include <stdlib.h>
#include <math.h>
#include <cstdio>

using namespace std;

struct point
{
	double left, right;
}p[2010], temp;

bool operator < (point a, point b)
{
	return a.left < b.left;
}

int main()
{
	int n;
	double r;
	int kase = 0;
	while (scanf("%d%lf",&n,&r)!=EOF &&(n || r))
	{
		bool flag = false;
		for (int i = 0; i < n; i++)
		{
			double a, b;
			scanf("%lf%lf",&a,&b);
			if (fabs(b) > r)
			{
				flag = true;
			}
			else
			{
				p[i].left = a * 1.0 - sqrt(r * r - b * b);
				p[i].right = a * 1.0 + sqrt(r * r - b * b);
			}
		}
		printf("Case %d: ",++kase);
		if (flag)
		{
			printf("-1\n");
		}
		else
		{
			int countt = 1;
			sort(p, p + n);
			temp = p[0];

			for (int i = 1; i < n; i++)
			{
				if (p[i].left > temp.right)
				{
					countt++;
					temp = p[i];
				}
				else if (p[i].right <=temp.right)
				{
					temp = p[i];
				}
			}
			printf("%d\n",countt);
		}
	}
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值