B - Radar Installation POJ - 1328

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

import java.util.ArrayList;
import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

/**
 * Created by 95112 on 11/12/2017.
 */
public class RadarInstallation {

    public static void main(String[] args)
    {
        ArrayList<String> answers = new ArrayList<String>();
        int times =1;
        Scanner scanner = new Scanner(System.in);
        int n,d;
        do {
            n = scanner.nextInt();
            d = scanner.nextInt();
            if (n==0 && d== 0)
                break;
            Island[] islands = new Island[n];
            int maxHeigh = 0;
             for (int i =0; i < n; i++)
            {
                int x ,y;
                x = scanner.nextInt();
                y = scanner.nextInt();
                if (maxHeigh<y)
                    maxHeigh = y;
                double dValue = Math.sqrt(d*d - y *y);
                islands[i] = new Island(x - dValue,x + dValue);
            }
            if (maxHeigh > d)
            {
                answers.add("Case "+times+": -1");
                times++;
                continue;
            }
            Arrays.sort(islands, new Comparator<Island>() {
                @Override
                public int compare(Island o1, Island o2) {
                    if (o1.left < o2.left)
                        return  -1;
                    else
                        return 1;

                }
            });
             int count = 0;
             double end = -999999999999999999999999.0;
             for (int i =0 ; i< n; i++){
                 if (islands[i].left <= end){
                     if (islands[i].right < end)
                         end = islands[i].right;
                 }else {
                     count++;
                     end = islands[i].right;

                 }
             }
            answers.add("Case "+times+": "+count);
            times++;
        }while (true);
        for (String answer : answers){
            System.out.println(answer);
        }
    }

}
class Island{
    double left;
    double right;
    public Island(double x,double y)
    {
        left = x;
        right = y;
    }
}
POJ - 3616是一个题目,题目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问题的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值