Taking Pebbles

There is a pile of N pebbles initially. Alice and Bob are playing a taking pebbles game as follows:
    Alice and Bob moves by turns, Alice moves first. For each move, the player can takes away at least one and at most half of the pebbles remained (“at most half” means you can take way at most k (k >= 1) pebbles if there are 2*k or 2*k+1 pebbles remained). If there is only one pebble remained, the player can also take away this pebble. The player who takes away the last pebble wins.
    If Alice and Bob are both clever enough, and they both want to be the winner, who will win?

Input

    The first line has one integer T (1 <= T <= 200), means there are T test cases.
    For each test case, there is only one line with an integer N (2 <= N <= 109), means the number of pebbles initially.

Output

    For each test case, print “Alice” (without quotation marks) in one line if Alice will win. Otherwise print “Bob” (without quotation marks) instead.

Sample Input

5
2
3
4
5
6

Sample Output

Bob
Alice
Alice
Bob
Alice

 

 

给你n个石头,以次至少取一个,最多取n/2,n==3 取3/2=1个。Alice先取,
轮流取,谁最后拿完石头就是谁win
刚开始想从奇偶性出发,考虑留给对方多少个时就能赢,但
考虑到每次取的最多的石头数量根本不是固定的,这就没法完了

发现首项为2,只要满足x=2*i+1这个序列的数都市Bob win。
其实从题目就可以看出,最后的结果只能和n本身有关,既然
奇偶性没关系,就试着从n的规律出发

 

 

#include<iostream>
#include<cstdio>
#include<bits/stdc++.h>
#define M 100100
using namespace std;
set<int>it;
/*aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa*/
int main()
{
    int st=2;it.insert(2);
    while(st*2+1<=1000000000){
        st=st*2+1;
        it.insert(st);
    }
    int t;cin>>t;
    while(t--){
        int n;cin>>n;
        it.count(n)?printf("Bob\n"):printf("Alice\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值