POJ 2367 Genealogical tree(Java)

The system of Martians’ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there’s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member’s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
Output
The standard output should contain in its only line a sequence of speakers’ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output
2 4 5 3 1

第一次写拓扑排序…..简直扑街。忘了把开始排序的那个点标记visited了…..

看了一下拓扑排序的原理就开始写,师兄表示这方法很暴力,提到了记录入度。然而还没有学会…..先把这题丢上来,留待以后继续学习。

public class Main {
    static vertex[] martians = new vertex[105];
    static Set<Integer> visited = new HashSet<Integer>();
    static Stack<Integer> ans = new Stack<Integer>();

    public static void main(String[] args) {
        Scanner reader = new Scanner(System.in);
        int n = reader.nextInt();
        for (int i = 1, get = 0; i <= n; i++) {
            get = reader.nextInt();
            ArrayList<Integer> child = new ArrayList<Integer>();
            while (get != 0) {
                child.add(get);
                get = reader.nextInt();
            }
            martians[i] = new vertex(child);
        }
        for (int i = 1; i <= n; i++) {
            if (!visited.add(i)) {
                continue;
            }
            topologicSort(i);
        }
        for (int i = 0; i < n; i++) {
            System.out.print(ans.pop());
            if (i < n - 1) {
                System.out.print(" ");
            }
        }
    }

    public static void topologicSort(int start) {
        ArrayList<Integer> child = martians[start].child;
        for (int i = 0, len = child.size(); i < len; i++) {
            int get = child.get(i);
            if (!visited.add(get)) {
                continue;
            }
            if (martians[get].child.isEmpty()) {
                ans.add(get);
                continue;
            }
            topologicSort(get);
        }
        ans.add(start);
        // System.out.println(start);
    }
}

class vertex {
    ArrayList<Integer> child;

    public vertex(ArrayList<Integer> child) {
        this.child = child;
    }
}

这个递归写的我自我感觉两行,结果wa哭。

这里写图片描述

Topologic Bomber Dragon镇,写拓扑永无bug。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值