MGRE全连及星型实验

 

 实验步骤:

第一步:进行子网划分,给每个接口配IP

PC:

IP网关
PC1192.168.1.1 24192.168.1.2 24
PC2192.168.2.1 24192.168.2.2 24
PC3192.168.3.1 24192.168.3.2 24
PC4192.168.4.1 24192.168.4.2 24
PC5192.168.5.1 24192.168.5.2 2

 路由:

R1

g0/0/0:192.168.2.1 24

g0/0/1:41.1.1 24

g0/0/2:14.1.1.1 24

R2

g0/0/0:192.168.2.2 24

g0/0/1:24.1.1.2 24

R3

g0/0/0:192.168.3.2 24

g0/0/1:34.1.1.3 24

R4

g0/0/0:41.1.1.4 24

g4/0/2:14.1.1.4 24

g0/0/1:24.1.1.4 24

g0/0/2:34.1.1.4 24

g4/0/0:64.1.1.4 24

g4/0/1:54.1.1.4 24

R5

g0/00:192.168.4.2 24

g0/0/1:54.1.1.5 24

R6

g0/0/0:192.168.5.2 24

g0/0/1:64.1.1.6 24

第二步:给每个接口配上IP地址

R1

配置代码

[R1]interface g0/0/0
[R1-GigabitEthernet0/0/0]ip add 192.168.1.2 24

[R1-GigabitEthernet0/0/0]int g0/0/1
[R1-GigabitEthernet0/0/1]ip add 41.1.1.1 24

[R1-GigabitEthernet0/0/1]int g0/0/2
[R1-GigabitEthernet0/0/2]ip add 14.1.1.1 24

 R2

配置代码

[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add 192.168.2.2 24

[R2-GigabitEthernet0/0/0]int g0/0/1
[R2-GigabitEthernet0/0/1]ip add 24.1.1.2 24

 R3

配置代码

[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip add 192.168.3.2 24

[R3-GigabitEthernet0/0/0]int g0/0/1
[R3-GigabitEthernet0/0/1]ip add 34.1.1.3 24

 R4

配置代码

[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip add 41.1.1.4 24

[R4-GigabitEthernet0/0/0]int g4/0/2
[R4-GigabitEthernet4/0/2]ip add 14.1.1.4 24

[R4-GigabitEthernet4/0/2]int g0/0/1
[R4-GigabitEthernet0/0/1]ip add 24.1.1.4 24

[R4-GigabitEthernet0/0/1]int g0/0/2
[R4-GigabitEthernet0/0/2]ip add 34.1.1.4 24

[R4-GigabitEthernet0/0/2]int g4/0/0
[R4-GigabitEthernet4/0/0]ip add 64.1.1.4 24

[R4-GigabitEthernet4/0/0]int g4/0/1
[R4-GigabitEthernet4/0/1]ip add 54.1.1.4 24

[R4]int LoopBack 0
[R4-LoopBack0]ip add 4.4.4.4 24

 R5

配置代码

[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip add 192.168.4.2 24

[R5-GigabitEthernet0/0/0]int g0/0/1
[R5-GigabitEthernet0/0/1]ip add 54.1.1.5 24

 R6

配置代码

[R6]int g0/0/0
[R6-GigabitEthernet0/0/0]ip add 192.168.5.2 24

[R6-GigabitEthernet0/0/0]int g0/0/1
[R6-GigabitEthernet0/0/1]ip add 64.1.1.4 24

 第三步:构建R1-2-3星型结构的MGRE,R1为中心站点

R1

配置代码

[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]ip add 10.1.1.1 24

[R1-Tunnel0/0/0]tunnel-protocol gre p2mp

[R1-Tunnel0/0/0]source 14.1.1.1

[R1-Tunnel0/0/0]nhrp entry multicast dynamic 

[R1-Tunnel0/0/0]nhrp network-id 100

 R2

配置代码

[R2]int Tunnel 0/0/0
[R2-Tunnel0/0/0]ip add 10.1.1.2 24

[R2-Tunnel0/0/0]tunnel-protocol gre p2mp

[R2-Tunnel0/0/0]nhrp network-id 100

[R2-Tunnel0/0/0]nhrp entry 10.1.1.1 14.1.1.1 register 

 R3

配置代码

[R3]int Tunnel 0/0/0
[R3-Tunnel0/0/0]ip add 10.1.1.3 24

[R3-Tunnel0/0/0]tunnel-protocol gre p2mp

[R3-Tunnel0/0/0]source 34.1.1.3

[R3-Tunnel0/0/0]nhrp network-id 100

[R3-Tunnel0/0/0]nhrp entry 10.1.1.1 14.1.1.1 register 

第四步:R1-5-6构建一个全连MGRE结构,R1和R5都为中心区域

R1

配置代码

[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]ip add 20.1.1.1 24

[R1-Tunnel0/0/1]tunnel-protocol gre p2mp

[R1-Tunnel0/0/1]source 41.1.1.1

[R1-Tunnel0/0/1]nhrp entry multicast dynamic 

[R1-Tunnel0/0/1]nhrp network-id 101

 

 R5

配置代码

[R5]int Tunnel 0/0/1
[R5-Tunnel0/0/1]ip add 20.1.1.2 24

[R5-Tunnel0/0/1]tunnel-protocol gre p2mp

[R5-Tunnel0/0/1]source 54.1.1.5

[R5-Tunnel0/0/1]nhrp entry multicast dynamic 

[R5-Tunnel0/0/1]nhrp network-id 101

 R6

配置代码

[R6]int Tunnel 0/0/1
[R6-Tunnel0/0/1]ip add 20.1.1.3 24

[R6-Tunnel0/0/1]tunnel-protocol gre p2mp

[R6-Tunnel0/0/1]source 64.1.1.6 
[R6-Tunnel0/0/1]nhrp entry 20.1.1.1 41.1.1.1 register 

[R6-Tunnel0/0/1]nhrp entry 20.1.1.2 54.1.1.5 register   
[R6-Tunnel0/0/1]nhrp network-id 101

 互相注册

[R1-Tunnel0/0/1]nhrp entry 20.1.1.2 54.1.1.5 register 

[R5-Tunnel0/0/1]nhrp entry 20.1.1.1 41.1.1.1 register 

 第五步:配置缺省路由并进项nat地址转换

R1

[R1]ip route-static 0.0.0.0 0 14.1.1.4
[R1]ip route-static 0.0.0.0 0 41.1.1.4
[R1-acl-basic-2000]rule permit source any

[R1]int g0/0/1 
[R1-GigabitEthernet0/0/1]nat outbound 2000

R2

 [R2]ip route-static 0.0.0.0 0 24.1.1.4
[R2]acl 2000
[R2-acl-basic-2000]rule permit source any
[R2-acl-basic-2000]int g0/0/1
[R2-GigabitEthernet0/0/1]nat  outbound 2000

R3

 [R3]ip route-static 0.0.0.0 0 34.1.1.4
[R3]acl 2000
[R3-acl-basic-2000]rule permit source any
[R3-acl-basic-2000]int g0/0/1
[R3-GigabitEthernet0/0/1]nat outbound 2000

R5

[R5]ip route-static 0.0.0.0 0 54.1.1.4
[R5]acl 2000
[R5-acl-basic-2000]rule permit source any
[R5-acl-basic-2000]int g0/0/1
[R5-GigabitEthernet0/0/1]nat outbound 2000

R6

[R6]ip route-static 0.0.0.0 0 64.1.1.4
[R6]acl 2000
[R6-acl-basic-2000]rule permit source any
[R6-acl-basic-2000]int g0/0/1

[R6-GigabitEthernet0/0/1]nat outbound 2000

第六步:ospf配置

R1

[R1]ospf 1 router-id 1.1.1.1
[R1-ospf-1]area 0
[R1-ospf-1-area-0.0.0.0]network 192.168.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 14.1.1.0 0.0.0.255
[R1-ospf-1-area-0.0.0.0]network 41.1.1.0 0.0.0.255

 

 

R2

[R2]ospf 1 router-id 2.2.2.2
[R2-ospf-1]area 0
[R2-ospf-1-area-0.0.0.0]net 192.168.2.0 0.0.0.255

[R2-ospf-1-area-0.0.0.0]net 10.1.1.0 0.0.0.255

 

R3

[R3]ospf 1 router-id 3.3.3.3
[R3-ospf-1]area 0

[R3-ospf-1-area-0.0.0.0]network 192.168.3.0 0.0.0.255
[R3-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255

 

R5

[R5]ospf 1 rou    
[R5]ospf 1 router-id 5.5.5.5

[R5-ospf-1]area 0
[R5-ospf-1-area-0.0.0.0]net 192.168.4.0 0.0.0.255
[R5-ospf-1-area-0.0.0.0]net 20.1.1.0 0.0.0.255

 

R6

[R6]ospf 1 router-id 6.6.6.6
[R6-ospf-1]area 0
[R6-ospf-1-area-0.0.0.0]net 192.168.5.0 0.0.0.255
[R6-ospf-1-area-0.0.0.0]net 20.1.1.0 0.0.0.255

 

第七步:将R1-2-3接口改为P2MP

R1

[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]ospf nerwork-type p2mp

R2

 [R2]int t0/0/0
[R2-Tunnel0/0/0]ospf network-type p2mp

R3

[R3]int Tunnel 0/0/0  
[R3-Tunnel0/0/0]ospf network-type p2mp

 第八步:将R1-5-6接口改为broadcast型

R1

[R1]int Tunnel 0/0/1    
[R1-Tunnel0/0/1]ospf network-type broadcast 

R5

[R5]int Tunnel 0/0/1
[R5-Tunnel0/0/1]ospf network-type broadcast 

R6

[R6]int Tunnel 0/0/1
[R6-Tunnel0/0/1]ospf network-type broadcast

查看R1是否学到路由:

 

第九步:测试全网可达

pc1 ping pc2

 

pc1 ping pc3

pc1 ping pc4

  

pc1ping pc5  

 

 pc1 ping R4环回

 

 R1 ping R6

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

俗庸203

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值