BZOJ1636Balanced Lineup

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 41718 Accepted: 19609
Case Time Limit: 2000MS
Description
For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
Source
USACO 2007 January Silver
线段树求区间最大&区间最小,再取个差即可。。
附上本蒟蒻的代码:

#include<cstdio>
#include<iostream>
#include<climits>
using namespace std;
struct edge
{
    int value;
};
edge node1[400001],node2[400001];
int n,m,i,p,q,a[400001];

void update1(int s)
{
    node1[s].value=max(node1[s*2].value,node1[s*2+1].value);
}

void update2(int s)
{
    node2[s].value=min(node2[s*2].value,node2[s*2+1].value);
}

void build1(int s,int l,int r)
{
    if (l==r)
      {
        node1[s].value+=a[l];
        return;
      }
    build1(s*2,l,(l+r)/2);
    build1(s*2+1,(l+r)/2+1,r);
    update1(s);
}

void build2(int s,int l,int r)
{
    if (l==r)
      {
        node2[s].value+=a[l];
        return;
      }
    build2(s*2,l,(l+r)/2);
    build2(s*2+1,(l+r)/2+1,r);
    update2(s);
}

int insert1(int s,int l,int r,int x,int y)
{
    int mid,ans=0;
    if (x<=l && y>=r)
      return node1[s].value;
    mid=(l+r)/2;
    if (x<=mid)
      ans=max(ans,insert1(s*2,l,mid,x,y));
    if (y>mid)
      ans=max(ans,insert1(s*2+1,mid+1,r,x,y));
    return ans;
}

int insert2(int s,int l,int r,int x,int y)
{
    int mid,ans;
    if (x<=l && y>=r)
      return node2[s].value;
    mid=(l+r)/2;
    if (x<=mid)
      ans=insert2(s*2,l,mid,x,y);
    else
      ans=INT_MAX;
    if (y>mid)
      ans=min(ans,insert2(s*2+1,mid+1,r,x,y));
    return ans;
}

int main()
{
    scanf("%d %d",&n,&m);
    for (i=1;i<=n;i++)
      scanf("%d",&a[i]);
    build1(1,1,n);
    build2(1,1,n);
    for (i=1;i<=m;i++)
      {
        scanf("%d %d",&p,&q);
        printf("%d\n",insert1(1,1,n,p,q)-insert2(1,1,n,p,q));
      } 
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值