I - Harmonic Number LightOJ - 1234

链接点击打开链接

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

思路:分段打表,100个数一个表。

Code:

#include<bits/stdc++.h>
using namespace std;
double b[1000005];
const int maxn=100000000;
void init ()
{
    int i;
    double temp=0;
    for(i = 1;i<=maxn;i++)
    {
        temp+=1/(i*1.0);
        if(i%100==0)
            b[i/100]=temp;
    }
}
int main()
{
    int T,n,x,i;
    init();
    scanf("%d",&T);
     for(int c=1;c<=T;c++)
     {
         scanf("%d",&n);
         x=n;
         x/=100;
         double res=b[x];

         for(i=x*100+1;i<=n;i++)
         {
             res+=1/(i*1.0);
         }
         printf("Case %d: %.10lf\n",c,res);
     }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值