HDU-2859 Phalanx

Phalanx

链接:传送

Phalanx

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2811    Accepted Submission(s): 1365


 

Problem Description

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc

 

 

Input

There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

 

 

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix.

 

 

Sample Input

 

3 abx cyb zca 4 zaba cbab abbc cacq 0

 

 

Sample Output

 

3 3

 思路:

二维DP,点(i,j)表示在此右上方包含的最大对称子矩阵个数。

那么状态转移可以下图看出

Code:

#include<bits/stdc++.h>
using namespace std;
char s[1005][1005];
int  dp[1005][1005], n;
int Judge(int a, int b)
{
    int x = a, y = b;
    while(x >= 1 && y <= n && s[x][b] == s[a][y])
        x--, y++;
    return a - x;
}
int main()
{
    int i, j;
    while(scanf("%d", &n) && n)
        {
            int res = 0, cnt;
            for(i = 1; i <= n; i++)
                scanf("%s", s[i] + 1);

            for(i = 1; i <= n; i++)
                dp[0][i] = dp[i][n] = 1;

            for(i = 1; i <= n; i++)
                for(j = n ; j >= 1; j--)
                    {
                        cnt = Judge(i, j);
                             if( cnt> dp[i - 1][j + 1])
                            {
                                //cout << i << ' ' << j << endl;
                                dp[i][j] = dp[i - 1][j + 1] + 1;
                            }
                        else dp[i][j] = cnt;
                        res = max(res, dp[i][j]);
                    }
       /* for(i = 1; i <= n; i++)
                {
                    for(j = 1; j <= n; j++)
                        cout << dp[i][j] << ' '; cout << endl;
                }*/
            printf("%d\n", res);

        }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值