Phalanx HDU - 2859

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC. 
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position. 
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs. 
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix: 
cbx 
cpb 
zcc

Input

There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix. 

Sample Input

3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output

3
3

题意:求最大对称子矩阵

思路:DP,dp[i][j]表示以(i,j)为左下角开始的最大矩阵长度,我们考虑从(i,j)向上和向右进行匹配,记录最长匹配长度,再比较dp[i-1][j+1]的值+1和最长匹配长度的大小,对dp[i][j]进行更新。

代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
using namespace std;
const int maxn = 5e4+100;
#define inf 0x3f3f3f3f
char a[100][100];
int dp[100][100];
int n;
int main(int argc, char const *argv[])
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%s",a[i]);
            dp[0][i]=1;
        }
        int ans=1;
        for(int i=0;i<n;i++)
        {
            for(int j=n-1;j>=0;j--)
            {
                int tmpi=i,tmpj=j;
                while(tmpi>=0&&tmpi<n&&tmpj>=0&&tmpj<n&&a[tmpi][j]==a[i][tmpj])
                {
                    tmpi--;
                    tmpj++;
                }
                int num=tmpj-j;
                if(dp[i-1][j+1]+1<=num)
                {
                    dp[i][j]=dp[i-1][j+1]+1;
                }
                else
                {
                    dp[i][j]=num;
                }
                ans=max(ans,dp[i][j]);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

还可以优化成1维dp,思考01背包的优化方法,我们只需要记录dp[j],因为i从0---n-1,所以我们只需要保证j+1始终是上一轮更新后的结果即可。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
using namespace std;
const int maxn = 5e4+100;
#define inf 0x3f3f3f3f
char a[100][100];
int dp[100];
int n;
int main(int argc, char const *argv[])
{
     #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
        freopen("out.txt","w",stdout);
    #endif
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%s",a[i]);
            dp[i]=1;
        }
        int ans=1;
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                int tmpi=i,tmpj=j;
                while(tmpi>=0&&tmpi<n&&tmpj>=0&&tmpj<n&&a[tmpi][j]==a[i][tmpj])
                {
                    tmpi--;
                    tmpj++;
                }
                int num=tmpj-j;
                if(dp[j+1]+1<=num)
                {
                    dp[j]=dp[j+1]+1;//保证上一轮的dp[j+1]没被更新
                }
                else dp[j]=num;
                ans=max(ans,dp[j]);
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值