hdu2859 Phalanx

Description

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC. 
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position. 
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs. 
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix: 
cbx 
cpb 
zcc
 

Input

There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.
 

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix. 
 

Sample Input

    
    
3 abx cyb zca 4 zaba cbab abbc cacq 0
 

Sample Output

    
    
3 3
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>

#define INF 0x3f3f3f3f

int dp[1005][1005];
char s[1005][1005];

int main()
{
    int i,j,sum,max,n;
    int x,y;

    while(scanf("%d",&n)==1)
    {
        if(n==0)
            break;
        for(i=0;i<n;i++)
            scanf("%s",s[i]);
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(i==0||j==n-1)
                {
                    dp[i][j]=1;
                    continue;
                }
                x=i;y=j;
                while(x>=0&&y<n&&s[x][j]==s[i][y])
                {
                    x--;
                    y++;
                }
                x=i-x;
                if(x>=dp[i-1][j+1]+1)
                    dp[i][j]=dp[i-1][j+1]+1;
                else
                    dp[i][j]=x;
            }
        }
        for(i=0,max=0;i<n;i++)
            for(j=0;j<n;j++)
            {
                if(max<dp[i][j])
                    max=dp[i][j];
            }
        printf("%d\n",max);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值