bzoj 3212: Pku3468 A Simple Problem with Integers 线段树

                                          bzoj 3212 线段树模板题

传送门:http://www.lydsy.com/JudgeOnline/problem.php?id=3212


Description

 
You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input


The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output


You need to answer all Q commands in order. One answer in a line.

 

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

HINT

The sums may exceed the range of 32-bit integers. 

这是bzoj中难得的模板题~~~~~

#include<cstdio>
#include<iostream>
#define MAXN 800010

using namespace std;

char op[10];int n,m;
struct Segtree{
  #define lc(x) x<<1
  #define rc(x) ((x<<1)|1)
  int l[MAXN],r[MAXN];
  long long add[MAXN],s[MAXN];
  void update(int x)
  {
    s[x]=s[lc(x)]+s[rc(x)];

  }
  void push(int x)
  {
     s[lc(x)]+=add[x]*(r[lc(x)]-l[lc(x)]+1);
     s[rc(x)]+=add[x]*(r[rc(x)]-l[rc(x)]+1);
     add[lc(x)]+=add[x];
     add[rc(x)]+=add[x];
     add[x]=0;
  }
  long long  query(int x,int L,int R)
   {
       push(x);
      if(l[x]>R||r[x]<L)
        return 0;
      if(l[x]>=L&&r[x]<=R)
        return s[x];
      return query(lc(x),L,R)+query(rc(x),L,R);
   }
   void change(int x,int L,int R,int v)
   {
      push(x);
     if(l[x]>R||r[x]<L)
        return ;
     if(l[x]>=L&&r[x]<=R)
        {
            s[x]+=v*(r[x]-l[x]+1);
            add[x]=v;
            return ;
        }
        change(lc(x),L,R,v);
        change(rc(x),L,R,v);
        update(x);
   }
   void build(int x,int L,int R)
   {
       l[x]=L,r[x]=R,add[x]=0;
       if(L==R)
       {
           scanf("%lld",&s[x]);
           return ;
       }
       int mid=(L+R)/2;
       build(lc(x),L,mid);
       build(rc(x),mid+1,R);
       update(x);
   }
}seg;
int main()
{
   scanf("%d%d",&n,&m);
   seg.build(1,1,n);
   while(m--)
   {
      scanf("%s",op);
      if(op[0]=='C')
      {
          int l,r;long long  v;
          scanf("%d%d%lld",&l,&r,&v);
          seg.change(1,l,r,v);
      }
      else
      {
         int l,r;
         scanf("%d%d",&l,&r);
         printf("%lld\n",seg.query(1,l,r));
      }
   }
   return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值