bzoj 3212: Pku3468 A Simple Problem with Integers (线段树)

3212: Pku3468 A Simple Problem with Integers

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 1565   Solved: 676
[ Submit][ Status][ Discuss]

Description


You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval. 

Input


The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000. 
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000. 
Each of the next Q lines represents an operation. 
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000. 
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab. 

Output


You need to answer all Q commands in order. One answer in a line. 

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

HINT

The sums may exceed the range of 32-bit integers. 

Source

[ Submit][ Status][ Discuss]

题解: 线段树裸题。。。。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 100003
#define LL long long 
using namespace std;
int n,m;
LL a[N],delta[N*4],tr[N*4];
void update(int now)
{
	tr[now]=tr[now<<1|1]+tr[now<<1];
}
void build(int now,int l,int r)
{
	if (l==r)
	 {
	 	tr[now]=a[l];
	 	return;
	 }
	int mid=(l+r)/2;
	build(now<<1,l,mid);
	build(now<<1|1,mid+1,r);
	update(now);
}
void pushdown(int now,int l,int r)
{
	int mid=(l+r)/2;
	if (delta[now])
	{
		tr[now<<1]+=delta[now]*(LL)(mid-l+1);
		tr[now<<1|1]+=delta[now]*(LL)(r-mid);
	    delta[now<<1]+=delta[now];
	    delta[now<<1|1]+=delta[now];
	    delta[now]=0;
	}
}
void qjchange(int now,int l,int r,int ll,int rr,LL v)
{
	if (ll<=l&&r<=rr)
	{
		delta[now]+=v; tr[now]+=v*(LL)(r-l+1);
		return;
	}
	int mid=(l+r)/2;
	pushdown(now,l,r);
	if (ll<=mid)  qjchange(now<<1,l,mid,ll,rr,v);
	if (rr>mid) qjchange(now<<1|1,mid+1,r,ll,rr,v);
	update(now);
}
LL qjsum(int now,int l,int r,int ll,int rr)
{
	if (ll<=l&&r<=rr) return tr[now];
	int mid=(l+r)/2;
	pushdown(now,l,r);
	LL ans=0;
	if (ll<=mid) ans+=qjsum(now<<1,l,mid,ll,rr);
	if (rr>mid) ans+=qjsum(now<<1|1,mid+1,r,ll,rr);
	return ans;
}
int main()
{
	scanf("%d%d",&n,&m);
	for (int i=1;i<=n;i++)
	 scanf("%lld",&a[i]);
	build(1,1,n);
	for (int i=1;i<=m;i++)
    {
      char s[10]; LL z;  int x,y;
	  scanf("%s%d%d",s,&x,&y);
	  if (s[0]=='C'){
	  	scanf("%lld",&z);
	    qjchange(1,1,n,x,y,z);
	  }	
	  else printf("%lld\n",qjsum(1,1,n,x,y));
	}	
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值