Find a multiple 【poj-2356】【抽屉原理】

Find a multiple
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8657 Accepted: 3745 Special Judge

Description

The input contains N natural (i.e. positive integer) numbers ( N <= 10000 ). Each of that numbers is not greater than 15000. This numbers are not necessarily different (so it may happen that two or more of them will be equal). Your task is to choose a few of given numbers ( 1 <= few <= N ) so that the sum of chosen numbers is multiple for N (i.e. N * k = (sum of chosen numbers) for some natural number k).

Input

The first line of the input contains the single number N. Each of next N lines contains one number from the given set.

Output

In case your program decides that the target set of numbers can not be found it should print to the output the single number 0. Otherwise it should print the number of the chosen numbers in the first line followed by the chosen numbers themselves (on a separate line each) in arbitrary order. 

If there are more than one set of numbers with required properties you should print to the output only one (preferably your favorite) of them.

Sample Input

5
1
2
3
4
1

Sample Output

2
2
3

题意:输入n,给出n个数,问能否在其中找出几个数的和是n的倍数。若能,则输出个数,及那几个数的值;若不能,则输出0.

题解:先得到数组的前n项和sum[i]=a[1]+a[2]+......+a[i],然后对sum[]取余,并记录余数分别为0~n-1时的数目rem[i]。若rem[0]大于0,及存在余数为0的sum[i],此时1~i即为解。若rem[0]等于0,即不存在余数为0的sum,此时n个sum的余数要放在n-1个抽屉中,即这n个数的余数只能是1~n-1中的一个;此时至少一个抽屉(即一个余数)对应着两个或两个以上的数。找出其中一个对应的范围,输出答案。


代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=10005;
int a[maxn];
int sum[maxn];
int rem[maxn];
int main()
{
	int n;
	while(~scanf("%d",&n)){
		memset(sum,0,sizeof(sum));
		memset(rem,0,sizeof(rem));
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
			sum[i]=sum[i-1]+a[i];
			rem[sum[i]%n]++;
		}
		if(rem[0]>=1){
			int i;
			for(i=1;i<=n;i++){
				if(sum[i]%n==0) break;
			}
			printf("%d\n",i);
			for(int j=1;j<=i;j++)
				printf("%d\n",a[j]);
			
		}else{
			int i;
			for(i=0;i<n;i++){
				if(rem[i]>=2) break;
			}
			int p=0,q=0;
			for(int j=1;j<=n;j++){
				if(sum[j]%n==i&&p==0){
					p=j;
				}else if(sum[j]%n==i&&p!=0&&q==0){
					q=j;
					break;
				}
				
			}
			
			printf("%d\n",q-p);
			for(int j=p+1;j<=q;j++){
				printf("%d\n",a[j]);
			}
		}
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值