【求助】zoj 2476求和水题

据说是个水题,不过还是总WA。。求大神给瞄一眼。
题目描述如下:
Total Amount
Time Limit: 2 Seconds      Memory Limit: 65536 KB
Given a list of monetary amounts in a standard format, please calculate the total amount.


We define the format as follows:


1. The amount starts with '$'.


2. The amount could have a leading '0' if and only if it is less then 1.


3. The amount ends with a decimal point and exactly 2 following digits.


4. The digits to the left of the decimal point are separated into groups of three by commas (a group of one or two digits may appear on the left).




Input


The input consists of multiple tests. The first line of each test contains an integer N (1 <= N <= 10000) which indicates the number of amounts. The next N lines contain N amounts. All amounts and the total amount are between $0.00 and $20,000,000.00, inclusive. N=0 denotes the end of input.




Output


For each input test, output the total amount.




Sample Input


2
$1,234,567.89
$9,876,543.21
3
$0.01
$0.10
$1.00
0




Sample Output


$11,111,111.10
$1.11

问题代码如下:

// ZOJ 2476.cpp : 定义控制台应用程序的入口点。
//


#include <iostream>
using namespace std;


int main()
{
	int n,totalLeft,totalRight,dotLeft,dotRight;
	char ch;
	while(cin>>n&&n!=0)
	{
		totalLeft=0;
		totalRight=0;
		for(;n>0;n--)
		{
			cin>>ch;
			int sum=0;
			while(ch!='.')
			{
				cin>>dotLeft;
				sum+=dotLeft;
				cin>>ch;
				if(ch==',')sum*=1000;
			}
			totalLeft+=sum;
			cin>>dotRight;
			totalRight+=dotRight;


		}
		totalLeft+=totalRight/100;
		cout<<"$";
		int baseNum=10000000,numOfZero=7,flag=0;
		
		while(numOfZero)
		{
			if(flag==0&&totalLeft/baseNum)
			{
				cout<<totalLeft/baseNum;
				flag=1;
			}
			else if(flag){
				if((numOfZero+1)%3==0)cout<<',';
				cout<<totalLeft/baseNum;
			}
			totalLeft%=baseNum;
			baseNum/=10;
			numOfZero--;
		}
		cout<<totalLeft<<'.';
		totalRight%=100;
		if(totalRight==0)cout<<"00"<<endl;
		else cout<<totalRight<<endl;




	}
	
	//int sum=0;


	
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值