HDU 2488 A Knight's Journey DFS


A Knight's Journey
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

看到题目第一反应是八数码问题,但是出题人很好的给出了这一句:

Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line.

字典序最小的序列

也就是给了深搜的顺序

DFS解得:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <map>
#include <stack>
using namespace std;
typedef struct{
    int x,y;
}Node ;
int n,m;
stack <Node> ans;
int dir_x[]={-2,-2,-1,-1,1,1,2,2},//棋盘X方向和正常X方向一致向右
    dir_y[]={-1,1,-2,2,-2,2,-1,1};//棋盘Y正方向向下,所以要反过来
int vis[30][30];
int dfs(int x,int y,int num){
    if(x<=0||x>n||y<=0||y>m) return 0;
    if(vis[x][y]) return 0;
    num++;
    vis[x][y]=1;
    if(num==n*m){
        Node temp;
        temp.x=x;temp.y=y;
        ans.push(temp);
        return 1;
    }
    for(int i=0;i<8;i++){
        if(dfs(dir_x[i]+x,dir_y[i]+y,num)){
            Node temp;
            temp.x=x;temp.y=y;
            ans.push(temp);//用栈把序列存下来
            return 1;
        }
    }
    vis[x][y]=0;//一个方向上深搜失败后,要重新标记,释放用过的点
    return 0;
}
int main()
{
    int T;
    cin>>T;
    for(int asd=1;asd<=T;asd++){
        memset(vis,0,sizeof(vis));
        cin>>m>>n;
        cout<<"Scenario #"<<asd<<":"<<endl;
        if(dfs(1,1,0)){
            while(!ans.empty()){
                Node temp=ans.top();
                ans.pop();
                cout<<(char)(temp.x-1+'A')<<temp.y;
            }
            cout<<endl;
        }else
            cout<<"impossible"<<endl;
        if(asd!=T)//别忘了组与组之间换行
            cout<<endl;
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值