E - Farthest Nodes in a Tree

E - Farthest Nodes in a Tree

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Given a tree (a connected graph with no cycles), you have to find the farthest nodes in the tree. The edges of the tree are weighted and undirected. That means you have to find two nodes in the tree whose distance is maximum amongst all nodes.

Input
Input starts with an integer T (≤ 10), denoting the number of test cases.

Each case starts with an integer n (2 ≤ n ≤ 30000) denoting the total number of nodes in the tree. The nodes are numbered from 0 to n-1. Each of the next n-1 lines will contain three integers u v w (0 ≤ u, v < n, u ≠ v, 1 ≤ w ≤ 10000) denoting that node u and v are connected by an edge whose weight is w. You can assume that the input will form a valid tree.

Output
For each case, print the case number and the maximum distance.

Sample Input
2
4
0 1 20
1 2 30
2 3 50
5
0 2 20
2 1 10
0 3 29
0 4 50
Sample Output
Case 1: 100
Case 2: 80


#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int MAXN=1e6+10;
int dis[MAXN],head[MAXN];
bool vis[MAXN];
int edgenum,Tnode,ans,n;

struct Edge{
    int from;
    int to;
    int val;
    int next;
}edge[MAXN];

void init()
{
    memset(head,-1,sizeof(head));edgenum=0;
}

void addedge(int u,int v,int w)
{
    edge[edgenum].from=u;
    edge[edgenum].to=v;
    edge[edgenum].val=w;
    edge[edgenum].next=head[u];
    head[u]=edgenum++;
}

void bfs(int s)
{

    memset(dis,0,sizeof(dis));
    memset(vis,false,sizeof(vis));
    queue<int> que;
    que.push(s);vis[s]=true;dis[s]=0;//第一个入队的要提前标记 
    ans=0;

    while(!que.empty())
    {
        int now=que.front();que.pop();//取出节点 清除 
        for(int i=head[now];i!=-1;i=edge[i].next)
        {
            int go=edge[i].to;//访问与之相邻接的节点 
            if(!vis[go])//如果没访问过 访问 
            {
                if(dis[go]<dis[now]+edge[i].val)//更新距离 
                dis[go]=dis[now]+edge[i].val;
                vis[go]=true;//标记访问过 
                que.push(go);//入队 
            }
        }
    }
    for(int i=0;i<n;++i)
    {
          if(ans<dis[i])
          {
             ans=dis[i];
             Tnode=i;
          }
    }
}

int main()
{
    int kase=0,t,u,v,w,i;
    scanf("%d",&t);
    while(t--)
    {
        init();//初始化 
        scanf("%d",&n);
        for(i=1;i<n;++i)
        {
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
            addedge(v,u,w);
        }
        bfs(0);//从某一点开始搜索 搜到最远点 
        bfs(Tnode)//从最远点在搜索到另一最远点 
        printf("Case %d: %d\n",++kase,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值