B - Roads in the North POJ-2631

B - Roads in the North

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu
Submit

Status
Description
Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice.
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area.

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1.
Input
Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.
Output
You are to output a single integer: the road distance between the two most remote villages in the area.
Sample Input
5 1 6
1 4 5
6 3 9
2 6 8
6 1 7
Sample Output
22


#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;

const int MAXN=1e4+10;
int head[MAXN],dis[MAXN];
bool vis[MAXN];
int edgenum,ans,Tnode,n;

struct Edge{
    int from;
    int to;
    int val;
    int next;
}edge[MAXN];

void init()
{
    memset(head,-1,sizeof(head));edgenum=0;
}

void addedge(int u,int v,int w)
{
    edge[edgenum].from=u;
    edge[edgenum].to=v;
    edge[edgenum].val=w;
    edge[edgenum].next=head[u];
    head[u]=edgenum++;
}

void bfs(int s)
{
    memset(dis,0,sizeof(dis));memset(vis,false,sizeof(vis));
    ans=0;
    queue<int> que; que.push(s); vis[s]=true; dis[s]=0,Tnode=s;

    while(!que.empty())
    {
        int now=que.front(); que.pop();
        for(int i=head[now];i!=-1;i=edge[i].next)
        {
            int go=edge[i].to;
            if(!vis[go])
            {
                if(dis[go]<dis[now]+edge[i].val)
                dis[go]=dis[now]+edge[i].val;
                vis[go]=true;
                que.push(go);
                if(ans<dis[go])//灵活运用  此题中无节点数目  
                {
                   ans=dis[go];
                   Tnode=go;
                }
            }
        }
    }

}

int main()
{
    int u,v,w;
    init();//忘了你 连结果都不给一个 输入也输不进去 
   //   n=0;
    while(~scanf("%d%d%d",&u,&v,&w))
    {
    //  if(!u) break;  没有结束条件啊 
        addedge(u,v,w);
        addedge(v,u,w);
    //  ++n; 
    }
    bfs(1);//节点从0,1开始模板不用变 
    bfs(Tnode);
    printf("%d\n",ans);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值