POJ 1142 Smith Numbers【Euler分解质因数】

Smith Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 13574 Accepted: 4626

Description

While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 
4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input

The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output

For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775


题意:给点数N,分解质因数后,然后将所有的因子写成组成因子的各位数字之和,如果这个和与N的各位数字之和相等且·N不是素数,那么就符合题意,找出>N的最小的这个数;

思路:数据也不是很大,10^8,向上枚举就行了;

失误:没有注意那个隐含条件:素数不符合 以后数学题直接用LL吧;


AC代码:

#include<cstdio>

typedef long long LL; 
const LL MAXN=1LL<<50;//写小了 

LL eu=0;

LL BS(LL N)
{ 
    LL s=0;
    while(N)
    {
    	s+=N%10;
    	N/=10;
	}
	return s;
} 

LL Euler(LL N)
{
	LL i=0,sum=0; 
	eu=N;
	for(i=2;i*i<=N;++i)
	{
		 if(N%i==0)
		 {
		 	eu-=eu/i;
		 	LL tem=BS(i);
		 	while(N%i==0) 
		 	{
		 		sum+=tem;
		 		N/=i;
			 }
		 }
	}
	if(N>1)
	{
		eu-=eu/N;
		sum+=BS(N);
	}
	return sum;
}

int main()
{
	LL N,i;
	while(scanf("%lld",&N),N)
	{
		for(i=N+1;i<MAXN;++i)
		{
		    LL sum1=BS(i);
		    if(sum1==Euler(i)&&eu!=(i-1)) {
				break;
			}
	    }
	    printf("%lld\n",i);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值