POJ 3080 Blue Jeans【多串最长子串】

Blue Jeans
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16824 Accepted: 7478

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC. 

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

题意:求多个串的最长公共子串,长度相等时输出最小的子串;

思路:串的长度较小,直接枚举就行,想用后缀数组写,不过还没学会,感觉后缀数组解这些题好简单;  看宇神用KMP,还是不能灵活运用KMP,想想还是用EXKMP来写了,将第一个串看成模式串,找其他串和他的最长子串就行,枚举模式串的n个后缀的子串,匹配出最长的一个,记录,不断更新就行;

失误:写出来WA了两次,想不出来错误原因,找了测试数据,最后一组错了,。。。就是没注长度相同时输出字典序最小的一个,看成输出第一个匹配的了;


AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char S[13][100],T[100]; int ne[100],en[100];

void Get_ene(char *T,int *ne,int L)
{
	ne[0]=L; int i=0;
	while(i+1<L&&T[i]==T[i+1]) ++i;
	ne[1]=i; int id=1;
	for(i=2;i<L;++i)
	{
		int mx=id+ne[id]-1,ll=ne[i-id];
		if(i+ll-1>=mx) {
			int j=max(0,mx-i+1);
			while(i+j<L&&T[i+j]==T[j]) ++j;
			ne[i]=j; id=i;
		}
		else ne[i]=ll;
	}
}
int EXKMP(char *S,char *T,int LS,int LT)
{
	int i=0;
	while(i<LT&&i<LS&&T[i]==S[i]) ++i;
	en[0]=i; int id=0,ans=en[0];
	for(i=1;i<LS;++i)
	{
		int mx=id+en[id]-1,ll=ne[i-id];
		if(i+ll-1>=mx) {
			int j=max(0,mx-i+1);
			while(i+j<LS&&j<LT&&T[j]==S[i+j]) ++j;
			en[i]=j; id=i;
		} 
		else en[i]=ll;
		ans=max(ans,en[i]);
	}
	return ans;
}
int main()
{
	int t,i,j,N;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&N);
		scanf("%s",T); 
		int LT=strlen(T);
		for(i=1;i<N;++i) scanf("%s",S[i]);
		int len=0,id=0;
		for(i=0;i<LT;++i)
		{
			Get_ene(T+i,ne,LT-i);
			int l2=0x3f3f3f3f;
			for(j=1;j<N;++j)
			{
				int LS=strlen(S[j]);
				int l=EXKMP(S[j],T+i,LS,LT-i);
				if(l2>l) l2=l;
			}
			if(l2>len) {
				len=l2; id=i;
			}
			if(len==l2) {
				int k=0;
				for(k=0;k<len;++k) {
					if(T[id+k]>T[i+k])
					{
						id=i; break;
					}
				}
			}
 		}
 		if(len>=3) 
 		for(i=id;i<id+len;++i) printf("%c",T[i]);
 		else printf("no significant commonalities");
 		printf("\n");
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值