POJ 3070 Fibonacci 【矩阵快速幂取模 (模板)】

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13262 Accepted: 9430

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:



题意:用矩阵快速幂取模求斐波拉契的项;

思路:直接上模板就行,在相乘的过程中进行取模运算;

失误:矩阵快速幂的代码有点麻烦,尽量写的简化一点;


AC代码:

#include<cstdio>
#include<cstring>

typedef long long LL;
const LL MOD=10000;

struct Matrix{
	LL Mat[3][3];
};

Matrix ori,res;

Matrix Mat_mul(Matrix X,Matrix Y)
{
	Matrix Z; memset(Z.Mat,0,sizeof(Z.Mat));
	LL i=0,j=0,k=0;
	for(i=1;i<=2;++i)
	{
		for(k=1;k<=2;++k)
		{
			if(X.Mat[i][k]==0) continue;
			for(j=1;j<=2;++j)
			{
				Z.Mat[i][j]+=(X.Mat[i][k]*Y.Mat[k][j])%MOD;
				Z.Mat[i][j]%=MOD;
			}
		}
	}
	return Z; 
}

void Mat_Q(LL M)
{  
    ori.Mat[1][1]=1; ori.Mat[1][2]=1; 
    ori.Mat[2][1]=1; ori.Mat[2][2]=0;
    res.Mat[1][1]=res.Mat[2][2]=1;
	res.Mat[1][2]=res.Mat[2][1]=0;
	    
	while(M)
	{
		if(M&1) res=Mat_mul(res,ori);
		ori=Mat_mul(ori,ori);
		M>>=1;
	}
}
int main()
{
	LL N;
	while(~scanf("%lld",&N),~N)
	{	
	    if(N==0) printf("0\n");
		else if(N==1) printf("1\n");
		else {
	         Mat_Q(N-1);
			 printf("%lld\n",res.Mat[1][1]);		 
		}    
	} 
	return 0;
 } 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是Java解决POJ3233—矩阵序列问题的代码和解释: ```java import java.util.Scanner; public class Main { static int n, k, m; static int[][] A, E; public static void main(String[] args) { Scanner sc = new Scanner(System.in); n = sc.nextInt(); k = sc.nextInt(); m = sc.nextInt(); A = new int[n][n]; E = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { A[i][j] = sc.nextInt() % m; E[i][j] = (i == j) ? 1 : 0; } } int[][] res = matrixPow(A, k); int[][] ans = matrixAdd(res, E); printMatrix(ans); } // 矩阵乘法 public static int[][] matrixMul(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { c[i][j] = (c[i][j] + a[i][k] * b[k][j]) % m; } } } return c; } // 矩阵快速 public static int[][] matrixPow(int[][] a, int b) { int[][] res = E; while (b > 0) { if ((b & 1) == 1) { res = matrixMul(res, a); } a = matrixMul(a, a); b >>= 1; } return res; } // 矩阵加法 public static int[][] matrixAdd(int[][] a, int[][] b) { int[][] c = new int[n][n]; for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { c[i][j] = (a[i][j] + b[i][j]) % m; } } return c; } // 输出矩阵 public static void printMatrix(int[][] a) { for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { System.out.print(a[i][j] + " "); } System.out.println(); } } } ``` 解释: 1. 首先读入输入的n、k、m和矩阵A,同时初始化单位矩阵E。 2. 然后调用matrixPow函数求出A的k次矩阵res。 3. 最后将res和E相加得到结果ans,并输出。 4. matrixMul函数实现矩阵乘法,matrixPow函数实现矩阵快速,matrixAdd函数实现矩阵加法,printMatrix函数实现输出矩阵
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值