玲珑杯”ACM比赛 Round #4 G -- See car【Set】

Start Time:2016-11-05 12:00:00 End Time:2016-11-05 17:00:00 Refresh Time:2016-11-06 21:50:19 Private

G -- See car

Time Limit:2s Memory Limit:64MByte

Submissions:578Solved:218

DESCRIPTION

You are the god of cars, standing at (a, b) point.There are some cars at point (xi,yi)(xi,yi). If lots of cars and you are in one line, you can only see the car that is nearest to yourself. How many cars can you see?
It is guaranteed that xi>axi>a and yi>byi>b.

INPUT
There are multiple test cases.The first line is a number T (T  11 ≤11), which means the number of cases.For each case, first line has three integers a,b,n(109a,b109,0n105)a,b,n(−109≤a,b≤109,0≤n≤105).next nn lines, each line contains two integer (xi,yi)(109xi,yi109)(xi,yi)(−109≤xi,yi≤109), which means the position of car.
OUTPUT
one line --- the number of car that you can see.
SAMPLE INPUT
20 0 31 1 2 23 30 0 41 12 22 34 6
SAMPLE OUTPUT
12

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>

using namespace std;

typedef long long LL;
const int MAXN=1e5+11;

int main()
{
	int T; scanf("%d",&T);
	while(T--) {
		int a,b,N; scanf("%d%d%d",&a,&b,&N);
		set<double> Se;
		for(int i=0;i<N;++i)  {
			int x,y; scanf("%d%d",&x,&y);
			Se.insert((y-b)*1.0/(x-a));
		}
		printf("%d\n",Se.size());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值