HDU 2577 How to Type

How to Type


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input
  
  
3 Pirates HDUacm HDUACM

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

题意:计算输入一段字符需要按多少下键盘,输入大写的时候每个字母可以按一下Shift,也可以先按一下大写锁定,输入一串大写之后必须把Shift恢复原状。

考虑如果大写锁定开了再按Shift就是小写,这个情况比较多,不好想,用动态规划一个一个考虑最优情况,可以把每一个字母处理情况分为两种:按完大写锁定不立即恢复和按完大写立即恢复。前者设为dp[i][1],后者设为dp[i][0],操作最后补立即恢复的加一就可以了。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int dp[110][2];
int main()
{
    int t,i;
    char a[110];
    scanf("%d", &t);
    while(t--)
    {
        scanf("%s",a);
        if(a[0]<'a')
        dp[0][0]=2,dp[0][1]=2;
        else
        dp[0][0]=1,dp[0][1]=2;
        for(i=1;a[i];i++)
        {
            if(a[i]<'a')
            {
                dp[i][0]=min(dp[i-1][0]+2,dp[i-1][1]+2);
                dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+1);
            }
            else
            {
                dp[i][0]=min(dp[i-1][0]+1,dp[i-1][1]+2);
                dp[i][1]=min(dp[i-1][0]+2,dp[i-1][1]+2);
            }
        }
        printf("%d\n",min(dp[i-1][0],dp[i-1][1]+1));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值