hdoj-2577-How to Type (最少按键次数)

How to Type

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4657 Accepted Submission(s): 2109


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input
  
  
3 Pirates HDUacm HDUACM

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

Author
Dellenge

Source

HDU 2009-5 Programming Contest 



#include<stdio.h>  
#include<string.h>  
char s[110];  
int da_ju(int i){  
    if((s[i]>='A')&&(s[i]<='Z')) return 1;  
    return 0;  
}  
int caps=0;  
int fun(int i){  
    if(caps){  
          if(da_ju(i)) return 1;  
        else {  
           if(s[i+1]=='\0') {  //s[i] 是最后一个大写字母;  
            caps=0;  
            return 1;  
           }  
           else if(da_ju(i+1)) return 2;  //s[i] 是小写字母,而后跟的是大写字母,此时执行: shift+s[i]本身;  
           else if(!da_ju(i+1)){     //s[i]是小写字母,且紧跟在后的也是小写字母,此时要关闭 caps;  
                caps=0;   
                return 1;  
            }  
        }  
    }  
    else{//caps未开   
        if(da_ju(i)&&da_ju(i+1)) {  //caps未开,s[i]是大写字母,且紧跟在后的s[i+1] 也是大写字母,此时要打开caps;  
            caps=1;  
            return 3;    // caps的关闭操作始终归于使得caps打开的那个大写字母;
			  //实际上caps并未关闭,但它的关闭操作的按键数已经在打开时的同时就被计 
			//数在内了,以后再关闭caps时,只需要修改caps的值即可(即caps=0),而不需要再计算操作数 !!!!  
        }  
        else if(da_ju(i)){  // s[i]是大写,而s[i+1]是小写,执行: shift+s[i]  
            return 2;  
        }  
        else return 1;  //s[i]是小写字母,s[i+1]也是小写字母  
    }  
      
}  
int main(){  
    int t;  
    scanf("%d",&t);  
    while(t--){  
        caps=0;  
        scanf("%s",s);  
        int len=strlen(s);  
            s[len]='\0';  
        int res=0;  
        for(int i=0;i<len;++i){  
            res+=fun(i);  
        }  
        printf("%d\n",res);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值