【LCS与LIS】HDU 1423 Greatest Common Increasing Subsequence

Greatest Common Increasing Subsequence

Problem Description

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.
Sample Input
 
 
1 5 1 4 2 5 -12 4 -12 1 2 4

Sample Output

 
 
2

题意:求最大公共上升子序列。

基本模板,就时最大公共子序列加了个判断大小的条件,主要看怎么加进去。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=550;
int dp[MAXN][MAXN];
int a[MAXN];
int b[MAXN];
int n1,n2;
int main()
{
    int Case,i,j;
    scanf("%d",&Case);
    while(Case--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%d",&n1);
        for(i=1; i<=n1; i++)scanf("%d",&a[i]);
        scanf("%d",&n2);
        for(i=1; i<=n2; i++)scanf("%d",&b[i]);
        memset(dp,0,sizeof(dp));
        for(i=1; i<=n1; i++)
        {
            int ans=0;
            for(j=1; j<=n2; j++)
            {
                if(b[j]<a[i]&&ans<dp[i-1][j])//始终吧最大的值给ans,比出递增。
                    ans=dp[i-1][j];
                if(a[i]==b[j])
                    dp[i][j]=ans+1;
                else
                    dp[i][j]=dp[i-1][j];
            }
        }
        /*for(i=1; i<=n1; i++)
        {
            for(j=1; j<=n2; j++)
                printf("%d ",dp[i][j]);
            printf("\n");
        }*/
        int ans=0;
        for(int i=1; i<=n2; i++)
            ans=max(ans,dp[n1][i]);
        printf("%d\n",ans);
        if(Case)
            printf("\n");
    }
    return 0;
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值