hdu1423---Greatest Common Increasing Subsequence(最长公共上升子序列)

http://acm.hdu.edu.cn/showproblem.php?pid=1423

Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
  
  
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
  
  
2 代码实现:
#include <iostream>
#include <cstring>
using namespace std;
int a[501],b[501];
int dp[501][501];
int main()
{
    int t,len1,len2,max;
    cin>>t;
    while(t--)
    {

        memset(dp,0,sizeof(dp));
        cin>>len1;
        for(int i=1; i<=len1; i++)
        {
            cin>>a[i];
        }
        cin>>len2;
        for(int j=1; j<=len2; j++)
        {
            cin>>b[j];
        }
        for(int i=1; i<=len1; i++)
        {
            max=0;
            for(int j=1; j<=len2; j++)
            {
                dp[i][j]=dp[i-1][j];
                if(a[i]>b[j]&&max<dp[i-1][j])
                {
                    max=dp[i-1][j];
                }
                if(a[i]==b[j])
                {
                    dp[i][j]=max+1;
                }
            }
        }
        max=0;
        for(int j=1; j<=len2; j++)
        {
            if(max<dp[len1][j])
            {
                max=dp[len1][j];
            }
        }
        cout<<max<<endl;
        if(t)
        {
            cout<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值