【区间dp】poj 1651 Multiplication Puzzle

Multiplication Puzzle

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000


If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

题意:给出一列数,需要把中间数子逐个提取出来,取的时候消耗能量是该数字和两边数字的积,例如样例取出1,消耗是10*1*50,最后求提取除头尾的中间所有数字消耗能量之和最小是多少。

用到了区间dp,来分区间进行动态规划,三层循环,最外层是划定区间范围大小,第二层确定边界,最里面是在边界中遍历,k为最后取的数子。

/**区间DP*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define INF 0xfffffff
#define MAXN 110
int dp[MAXN][MAXN], a[MAXN];
int main ()
{
	int n;
	while(~scanf ("%d", &n))
	{
		for (int i = 0; i < n; i++)
			scanf ("%d", &a[i]);
		memset(dp,0,sizeof(dp));
		for (int len = 2; len < n; len++)//len是区间包含的长度减一
		{
			for(int i =0; i <n-len; i++)
			{
				int j = i+len;//区间终点
				dp[i][j] = INF;
				for (int k = i+1; k < j; k++)
					dp[i][j] = min(dp[i][j], dp[i][k]+dp[k][j]+a[i]*a[k]*a[j]);
			}
		}
		printf ("%d\n", dp[0][n-1]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值