find the longest of the shortest HDU - 1595(最短路径之记录路径)

Problem Description

Marica is very angry with Mirko because he found a new girlfriend and she seeks revenge.Since she doesn’t live in the same city, she started preparing for the long journey.We know for every road how many minutes it takes to come from one city to another.
Mirko overheard in the car that one of the roads is under repairs, and that it is blocked, but didn’t konw exactly which road. It is possible to come from Marica’s city to Mirko’s no matter which road is closed.
Marica will travel only by non-blocked roads, and she will travel by shortest route. Mirko wants to know how long will it take for her to get to his city in the worst case, so that he could make sure that his girlfriend is out of town for long enough.Write a program that helps Mirko in finding out what is the longest time in minutes it could take for Marica to come by shortest route by non-blocked roads to his city.

Input

Each case there are two numbers in the first row, N N N and M M M, separated by a single space, the number of towns,and the number of roads between the towns. 1 ≤ N ≤ 1000 , 1 ≤ M ≤ N ∗ ( N − 1 ) / 2 1 ≤ N ≤ 1000, 1 ≤ M ≤ N*(N-1)/2 1N1000,1MN(N1)/2. The cities are markedwith numbers from 1 1 1 to N N N, Mirko is located in city 1 1 1, and Marica in city N N N.
In the next M lines are three numbers A , B A, B A,B and V V V, separated by commas. 1 ≤ A , B ≤ N , 1 ≤ V ≤ 1000 1 ≤ A,B ≤ N, 1 ≤ V ≤ 1000 1A,BN,1V1000.Those numbers mean that there is a two-way road between cities A A A and B B B, and that it is crossable in V V V minutes.

Output

In the first line of the output file write the maximum time in minutes, it could take Marica to come to Mirko.

Sample Input

5 6
1 2 4
1 3 3
2 3 1
2 4 4
2 5 7
4 5 1

6 7
1 2 1
2 3 4
3 4 4
4 6 4
1 5 5
2 5 2
5 6 5

5 7
1 2 8
1 4 10
2 3 9
2 4 10
2 5 1
3 4 7
3 5 10

Sample Output

11
13
27

题意:城市内有n条路,其中有某条路在修,因为这条路有很多情况,问各种情况下的最短路中最长的是哪条
思想:由于断开路径较多,但是有很大一部分断开之后不影响,排除不影响部分,在路全部畅通的情况下,记录此状态的路径,断开时只需要断开该路径上的一条路即可,理论上会超时,因为最坏的情况路有 1000 1000 1000 条,每次都调用迪杰斯特拉算法,则时间复杂度会达到 100 0 3 1000^{3} 10003,所以局部进行了优化,附代码:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#include<cstdio>
#define mem(a,b) memset(a,b,sizeof(a))
const int inf=0x3f3f3f3f;
bool b[1010];
int e[1010][1010];
int dis[1010],p[1010];
int n,m,minn;
void init() //对e[][]初始化
{
    for(int i=0; i<=n; i++)
        for(int j=0; j<=n; j++)
            if(i==j)
                e[i][j]=0;
            else
                e[i][j]=inf;
}
void dijkstra(int z)//迪杰斯特拉算法 
{
    mem(dis,inf);
    mem(b,0);
    dis[1]=0;
    int u;
    for(int i=1; i<=n; i++)
    {
        int minn=inf;
        for(int j=1; j<=n; j++)
        {
            if(!b[j]&&dis[j]<minn)
            {
                minn=dis[j];
                u=j;
            }
        }
        if(minn==inf)//优化,如果没有找到较小的,直接结束
            return ;
        b[u]=1;
        for(int v=1; v<=n; v++)
        {
            if(!b[v]&&dis[v]>dis[u]+e[u][v])
            {
                dis[v]=dis[u]+e[u][v];
                if(z)
                    p[v]=u;//p数组记录路径 ,即j点的下一个点
            }
        }
    }
    return ;
}
int main()
{
    while(cin>>n>>m)
    {
        init();
        mem(p,0);
        int a,b,c;
        for(int i=0; i<m; i++)
        {
            cin>>a>>b>>c;
            if(e[a][b]>c)
            {
                e[a][b]=c;
                e[b][a]=c;
            }
        }
        dijkstra(1);
        int maxx=dis[n];
        for(int i=n; i!=1; i=p[i])
        {
            int q=e[i][p[i]];//把当前点和路径上的当前点的下一个点断开 
            e[i][p[i]]=e[p[i]][i]=inf;
            dijkstra(0);
            maxx=max(maxx,dis[n]);
            e[i][p[i]]=e[p[i]][i]=q;
        }
        cout<<maxx<<endl;
    }
    return 0;
}

实践是检验真理的唯一标准

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值