HDU-1506 Largest Rectangle in a Histogram

Problem Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2 , 1 , 4 , 5 , 1 , 3 , 3 2, 1, 4, 5, 1, 3, 3 2,1,4,5,1,3,3, measured in units where 1 is the width of the rectangles:
在这里插入图片描述
Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 &lt; = n &lt; = 100000 1 &lt;= n &lt;= 100000 1<=n<=100000. Then follow n integers h 1 , . . . , h n h1, ..., hn h1,...,hn, where 0 &lt; = h i &lt; = 1000000000. 0 &lt;= hi &lt;= 1000000000. 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1 1 1. A A A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

题意:条形图的宽度全部为 1 1 1给出条形图的高度问条形图围成的最大面积是多少?
思路:首先要明白:条形图要想与其他条形图围成矩形那么他们的高度必须满足大于等于此条形图的高度;由此,我们可以枚举每一个条形图,把他当作最矮的,然后进行左右查询;
具体操作看代码吧:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long
const int N=1e5+1000;
ll a[N],l[N],r[N];
int main()
{
    int n;
    while(cin>>n&&n)
    {
        for(int i=1; i<=n; i++)
            cin>>a[i];
        l[1]=1;
        r[n]=n;
        for(int i=2; i<=n; i++)//求出每个矩形左端非递减连续的下标
        {
            int t=i;
            while(t>1&&a[i]<=a[t-1])
                t=l[t-1];
            l[i]=t;
        }
        for(int i=n-1; i>=1; i--)//求出每个矩形右端非递减连续的下标
        {
            int t=i;
            while(t<n&&a[i]<=a[t+1])
                t=r[t+1];
            r[i]=t;
        }
        ll ans=0;
        for(int i=1; i<=n; i++)
            ans=max(ans,(r[i]-l[i]+1)*a[i]);
        cout<<ans<<endl;
    }
    return 0;
}
实践才是检验真理的唯一标准;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值