Wireless Network POJ - 2236(并查集)

Problem Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it.

But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A A A and computer B B B can communicate if computer A A A and computer B B B can communicate directly or there is a computer C C C that can communicate with both A A A and B B B. In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N N N and d ( 1 &lt; = N &lt; = 1001 , 0 &lt; = d &lt; = 20000 ) d (1 &lt;= N &lt;= 1001, 0 &lt;= d &lt;= 20000) d(1<=N<=1001,0<=d<=20000). Here N N N is the number of computers, which are numbered from 1 1 1 to N N N, and D D D is the maximum distance two computers can communicate directly. In the next N N N lines, each contains two integers x i , y i ( 0 &lt; = x i , y i &lt; = 10000 ) xi, yi (0 &lt;= xi, yi &lt;= 10000) xi,yi(0<=xi,yi<=10000), which is the coordinate of N N N computers. From the ( N + 1 ) (N+1) (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:

  1. &quot; O p &quot; ( 1 &lt; = p &lt; = N ) &quot;O p&quot; (1 &lt;= p &lt;= N) "Op"(1<=p<=N), which means repairing computer p p p.
  2. &quot; S p q &quot; ( 1 &lt; = p , q &lt; = N ) &quot;S p q&quot; (1 &lt;= p, q &lt;= N) "Spq"(1<=p,q<=N), which means testing whether computer p p p and q q q can communicate.

The input will not exceed 300000 300000 300000 lines.

Output

For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意:
   有一个计算机网络的所有线路都坏了,网络中有 n n n台计算机,现在你可以做两种操作,修理 O O O 和检测两台计算机是否连通 S S S,只有修理好的计算机才能连通。连通有个规则,两台计算机的距离不能超过给定的 最大距离 D D D(一开始会给你 n n n台计算机的坐标)。检测的时候输出两台计算机是否能连通

思路:
   并查集的简单应用;本人用了一个结构体,记录各个电脑的状态;按照题中所给的条件对电脑进行更新,然后进行遍历访问电脑看是否合并为一个整体集合就欧克了!

注意:
   算距离的时候不能算根节点到当前电脑的距离!!!

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
int a[1005],b[1005];
struct node
{
    double x,y;
} p[1005];
int getf(int x)
{
    if(x==b[x])
        return x;
    return b[x]=getf(b[x]);
}
void merge(int x,int y)
{
    int a,c;
    a=getf(x);
    c=getf(y);
    if(a!=c)
        b[c]=a;
}
int main()
{
    int x,y,n;
    double d;
    char c[2];
    cin>>n>>d;
    memset(a,0,sizeof(a));
    for(int i=0; i<1005; i++)
        b[i]=i;
    for(int i=1; i<=n; i++)
        cin>>p[i].x>>p[i].y;
    n=0;
    while(cin>>c)
    {
        if(c[0]=='O')
        {
            cin>>x;
            for(int i=0; i<n; i++)
            {
                double tx=p[a[i]].x,ty=p[a[i]].y,ex=p[x].x,ey=p[x].y;
                double l=sqrt((tx-ex)*(tx-ex)+(ty-ey)*(ty-ey)+0.0);
                if(l<=d)
                    merge(a[i],x);
            }
            a[n++]=x;
        }
        if(c[0]=='S')
        {
            cin>>x>>y;
            if(getf(x)==getf(y))
                puts("SUCCESS");
            else
                puts("FAIL");
        }
    }
    return 0;
}

实践是检验真理的唯一标准

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值