POJ 2236 Wireless Network

Wireless NetworkTime Limit: 10000MS Memory Limit: 65536KTotal Submissions: 18917 Accepted: 7957DescriptionAn earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team)
摘要由CSDN通过智能技术生成
Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 18917 Accepted: 7957

Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL

SUCCESS

用了一上午的时间,终于过了,激动啊,,,

首先这题只有一个测试案例,第一行是有n个电脑,彼此之间的距离小于等于d才能通信。

第二点,每修好一个电脑,就把这台电脑和之前已经修好的电脑比较,如果能连到一起,就归为一个集合,因为我在写代码的时候,加了一个break;

就是说只要这台电脑和其中一台属于一个集合的话,就退出循环,禁止这台电脑和之后的电脑匹配,这样就出现了问题,应该将这台电脑和所有电脑都匹配一下,找出所以集合。

最后,提交老是re,以为是数组开的太小了,把所有数组都放大放大,还是re,后来发现,也是开始做题的时候一直发现的,输入操作命令时,一直在输,没有停止的时候,最后在这一个关键点出现错误,把输入字符串改为while(scanf("%s",opr)!=EOF)也就是说,读入字符串到文件的结尾的时候,程序就停止了。提交AC。



#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int n;
int par[1005];
int rank[1005];
struct computer
{
    int x,y;
}c[1005];
//初始化并查集
void init()
{
    for(int i=1;i<=n;i++)
    {
        par[i]=i;
        rank[i]=0;
    }
}

int find(int x)
{
    if(par[x]==x)
    {
        return x;
    }
    else{
        return par[x]=find(par[x]);
    }
}
//集合x,y合并
void unite(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x==y) return;
    if(rank[x]<rank[y])
    {
        par[x]=y;
    }
    else
    {
        par[y]=x;
        if(rank[x]==rank[y])
            rank[x]++;
    }
}
//判断x,y是否属于一个集合
bool same(int x,int y)
{
    return find(x)==find(y);
}

double dis(int e,int d)
{
    return 1.0*sqrt((c[e].x-c[d].x)*(c[e].x-c[d].x)+(c[e].y-c[d].y)*(c[e].y-c[d].y));
}

int main(void)
{
   // freopen("A.txt","r",stdin);

    double d;
    while(scanf("%d%lf",&n,&d)!=EOF)
    {

        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&c[i].x,&c[i].y);
        }
        init();
        getchar();
        char opr[10];
        int k=0;
        int a[300005];
        while(scanf("%s",opr)!=EOF)
        {
            if(opr[0]=='O')
                {
                    int aa;
                    scanf("%d",&aa);
                    a[++k]=aa;
                    for(int i=1;i<k;i++)
                    {
                        if(dis(a[k],a[i])<=d)
                        {
                            unite(a[k],a[i]);

                        }
                    }
                }
            else if(opr[0]=='S')
            {
             int bb,cc;
             scanf("%d%d",&bb,&cc);
                if(same(bb,cc))
                    printf("SUCCESS\n");
                else
                    printf("FAIL\n");
            }
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值