NYOJ791-Color the fence

题目链接                                    Color the fence

时间限制:1000 ms  |  内存限制:65535 KB

难度:2

描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to 

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint. 

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入

There are multiple test cases.
Each case the first line contains a nonnegative integer V(0≤V≤10^6).
The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).

输出

Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.

样例输入

5
5 4 3 2 1 2 3 4 5
2
9 11 1 12 5 8 9 10 6

样例输出

55555
33

来源

CodeForce

上传者

TC_李远航

思路:贪心,思路很简单,油量除以最小耗油量得到最长位数,在该长度下找到最大的数,看例子

如果为

5
5 4 3 2 1 2 3 4 5

那直接就是55555

如果为

5

2 2 2 2 2 3 3 3 3

95为正确答案

具体怎么实现自己先思考,代码上有注释。

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
	int n,k[10],mi,i,num,s,liter;
	while(scanf("%d",&n)!=EOF)
	{
		mi=999999;
	    for(i=1;i<=9;i++){
	    	scanf("%d",&k[i]);
	    	if(mi>k[i]) mi=k[i];//如果最小值还大于总油量,那么输出-1
		}
		if(mi>n) printf("-1");
		else{//会有油量为5//耗油量2 2 2 2 2 3 3 3 3这种情况出现  
		    s=n/mi;//得到最长位数 
			while(n){//所以在保证位数最长的情况下,选最大的数字 
			    num=0;
				for(i=1;i<=9;i++){
					int temp=(n-k[i])/mi;//如果油量为5//耗油量2 2 2 2 2 3 3 3 3会有下面的情况 
					if(temp==s-1&&i>num&&(n-k[i])>=0){//(n-k[i])/mi==s-1    (2-3)/mi==1-1; 
						num=i;
						liter=k[i];
					}
				}
				if(num){
					n-=liter;
					s--;
					printf("%d",num);
				}
				if(n<mi||s==0) break;
			} 
		}
		printf("\n");
	}
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值