HDU 4597 Play Game(DFS,区间DP)

Play Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1274 Accepted Submission(s): 737

Problem Description
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input
The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai (1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

Output
For each case, output an integer, indicating the most score Alice can get.

Sample Input
2

1
23
53

3
10 100 20
2 4 3

Sample Output
53
105

dp[x1][y1][x2][y2]表示当前先手的这个人在x1到y1,x2到y2,两堆的区间,可以获得最大值,dp[x1][y1][x2][y2]的值等于当前的和 sum-(下一个状态,即对方先手可以获得的最大值)。

关于区间DP,可以参照这个博客
http://blog.csdn.net/dacc123/article/details/50885903

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int dp[30][30][30][30];
int a[30];
int b[30];
int n;
int sum;
int dfs(int x1,int y1,int x2,int y2,int sum)
{
    if(dp[x1][y1][x2][y2])
        return dp[x1][y1][x2][y2];
    if((x1>y1)&&(x2>y2))
        return 0;
    int num=0;
    if(x1<=y1)
    {
        num=max(num,sum-dfs(x1+1,y1,x2,y2,sum-a[x1]));
        num=max(num,sum-dfs(x1,y1-1,x2,y2,sum-a[y1]));
    }
    if(x2<=y2)
    {
        num=max(num,sum-dfs(x1,y1,x2+1,y2,sum-b[x2]));
        num=max(num,sum-dfs(x1,y1,x2,y2-1,sum-b[y2]));
    }
    dp[x1][y1][x2][y2]=num;
    return dp[x1][y1][x2][y2];
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&b[i]);
            sum+=b[i];
        }
        memset(dp,0,sizeof(dp));
        printf("%d\n",dfs(1,n,1,n,sum));
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值