HDU4597:Play Game(记忆化)

Problem Description
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
 

Input
The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤b i≤10000).
 

Output
For each case, output an integer, indicating the most score Alice can get.
 

Sample Input
  
  
2 1 23 53 3 10 100 20 2 4 3
 

Sample Output
  
  
53 105
dp[la][ra][lb][rb]记录的是在a的区间只剩下la~ra,b的区间只剩下lb~rb的时候,Alice能得到的最大值
那么只需要考虑四种不同的取法并从中取得最优的方案,sum-(Alice上一个状态中Bob拿的值)中取最大
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,dp[23][23][23][23],a[23],b[23];

int dfs(int la,int ra,int lb,int rb,int sum)
{
    int maxn = 0;
    if(la>ra && lb>rb) return 0;
    if(dp[la][lb][ra][rb]) return dp[la][lb][ra][rb];
    if(la<=ra)
    {
        maxn = max(maxn,sum-dfs(la+1,ra,lb,rb,sum-a[la]));
        maxn = max(maxn,sum-dfs(la,ra-1,lb,rb,sum-a[ra]));
    }
    if(lb<=rb)
    {
        maxn = max(maxn,sum-dfs(la,ra,lb+1,rb,sum-b[lb]));
        maxn = max(maxn,sum-dfs(la,ra,lb,rb-1,sum-b[rb]));
    }
    dp[la][lb][ra][rb] = maxn;
    return maxn;
}

int main()
{
    int t,i,j,sum;
    scanf("%d",&t);
    while(t--)
    {
        sum = 0;
        scanf("%d",&n);
        for(i = 1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        for(i = 1;i<=n;i++)
        {
            scanf("%d",&b[i]);
            sum+=b[i];
        }
        memset(dp,0,sizeof(dp));
        printf("%d\n",dfs(1,n,1,n,sum));
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值