线段树 查询删除 后序遍历 POJ2182 Lost Cows解题报告

       Lost Cows

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10347 Accepted: 6624
Description
N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood ‘watering hole’ and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he’s not very good at observing problems. Instead of writing down each cow’s brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.
Input
* Line 1: A single integer, N

  • Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
    Output
  • Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
    Sample Input
    5
    1
    2
    1
    0
    Sample Output
    2
    4
    5
    3
    1
    Source
    USACO 2003 U S Open Orange
    线段树解法,后序遍历。举题目的例子来说明方法:
    最后一只奶牛前面有0个比它小,说明在N只奶牛中它排在第1位,所以它的值是1;
    倒数第2只前面有1只比它小,说明在2 3 4 5中它排在了第2位,因此它的值是3;
    倒数第3只前面有2只比它小,说明在2 4 5中它排第3位,因此它的值是5;
    倒数第4只前面有1只比它小,说明在2 4中它排第2位,因此它的值是4;
    最后一只值就是2。
    叶子节点从1到N标号。线段树节点存放对应区间未确定序号的牛的数量。叶子节点从1到N标号。
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
#include<iostream>
#define MAXN 8005
#define Lson(x) ((x) << 1)
#define Rson(x) (((x) << 1) + 1)
using namespace std;
int N,data[MAXN],ans[MAXN];
struct node
{
    int L,R,Len;
}SegTree[MAXN * 4];
void Build(int L,int R,int Node){//口诀:赋值(一开始就能确定的成员,初始数据),判断(叶子),递归,(成员需要初始数据计算得到时)回溯
    SegTree[Node].L=L;SegTree[Node].R=R;//赋值
    SegTree[Node].Len=R-L+1;
    if(L==R) return ;//判断
    int _mid=(SegTree[Node].L+SegTree[Node].R)>>1;//递归
    Build(L,_mid,Lson(Node));
    Build(_mid+1,R,Rson(Node));
}
int query(int _data,int Node){//在剩下未确定的序号里面,寻找第_data个数在结果中的序号。前提条件:Node节点长度不小于_data
    SegTree[Node].Len--;
    if(SegTree[Node].L==SegTree[Node].R) return SegTree[Node].L;
    if(SegTree[Lson(Node)].Len>=_data) return query(_data,Lson(Node));//从左子树开始找
    else return query(_data-SegTree[Lson(Node)].Len,Rson(Node));//否则一定在右子树里面
}
int main()
{
    freopen("output.txt","w",stdout);
    freopen("input.txt","r",stdin);
    while(scanf("%d",&N)!=EOF){
        for(int i=2;i<=N;i++) scanf("%d",&data[i]);//从第二头牛开始输入
        Build(1,N,1);//节点存放区间未确定序号的牛的数量。叶子节点从1到N标号。
       // for(int i=1;i<4*N;i++)cout<<"#Node "<<i<<": "<<" "<<SegTree[i].L<<" "<<SegTree[i].R<<" "<<SegTree[i].Len<<endl;
        for(int i=N;i>=1;i--)  ans[i]=query(data[i]+1,1);//寻找第data[i]+1个的序号
        for(int i=1;i<=N;i++)  printf("%d\n",ans[i]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值