dfs:How Many Equations Can You Find

Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output
The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input
123456789 3
21 1

Sample Output
18
1

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
#include <vector>
#include <list>
#include <map>
#include <set>
#include <queue>
#include <cctype>
#include <cstdlib>
#include <sstream>
#define sqr(x) ((x)*(x))
#define lson le,mid,rt<<1
#define rson mid+1,ri,rt<<1|1
#define inf 0x3f3f3f3f
#define eps 1e-6
typedef long long ll;
using namespace std;
const double PI = 4.0*atan(1.0);
const int maxn =10 ;
int n,ans,len,f,e;
char s[30];
int temp;

void dfs(int a,int b)
{
  if(a==len)
  {
      if(b==n)
        ans++;
      return;
  }
  int temp=0;
  for(int i=a;i<len;i++)
  {
      temp=temp*10+s[i]-'0';
      dfs(i+1,b+temp);
      if(a!=0)
      dfs(i+1,b-temp);
  }
}
int main()
{
    while(scanf("%s%d",s,&n)!=EOF)
    {
        ans=0;
        len=strlen(s);
        dfs(0,0);
        printf("%d\n",ans);
    }
    return 0;
}

Reflect:
刚开始还想着把字符串分成前后两的部分,用front代表前面一部分的计算结果,end代表后面的结果,后来发现结果会被覆盖。。。还傻傻的分了三种情况,加入加号、减号和什么也不加
而这份代码中
1 , 在dfs函数中通过传参的方式传递结果,就不会有覆盖的问题;
2,通过一个for循环就解决了在两个数之间什么也不加的情况,然后分别计算加入减号和加号的情况;
3,还有一个要注意的情况,当你当前的位置是第一个位置时,就不可以进行减法运算,只可以进行加法运算;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值